Forums > MaxMSP

soundflower version probs

May 11, 2009 | 8:19 pm

hey

just *updated* soundflower/bed using the 1.4.3dmg from google

problem is, the version number for soundflower.pkg and soundflowerbed app have both gone backwards

soundflowerbed went from 1.2 to 1.1
and the soundflower.pkg went from 1.2.1 to 1.0

is this just bad numbering in the 1.4.3 installer or is it worse

any other way to check versions – looking in package contents also shows 1.0 for soundflower

what gives… can anyone concur or point to a better installer

cheers


May 12, 2009 | 5:03 pm

I don’t see this on my machine. When I get info on Soundflowerbed I see 1.4.3. What OS are you running?

-ben


May 12, 2009 | 9:29 pm

I’m on tiger + prior to installing second time round I cleared out *every* trace of soundflower/bed – it creates a clean folder and adds new packages but they report these earlier version numbers!
Curious that the version you have should be fine – are there multiple versions of the 1.4.3 dmg?


May 13, 2009 | 4:54 pm

I’ve just installed on Tiger, 10.4.11, with the latest available installer here:

http://code.google.com/p/soundflower/

And cannot reproduce your issue.

All I can suggest is doing a complete clean install.

If you are having difficulty removing Soundflower, open up a terminal and type:

ls /System/Library/Extensions/Soundflower.kext

if you see–
ls: /System/Library/Extensions/Soundflower.kext: No such file or directory

then soundflower is not on the system! You may need to restart just to make sure all applications do not still think it is loaded.

but if you see–
Contents

then soundflower is still installed.

Please type:
sudo kextunload /System/Library/Extensions/Soundflower.kext

[ you will have to enter your admin password ]

sometimes the unloading may fail and you need to do the command again one or two times [ type uparrow, return ]

once the unload is successful, then you can blow away soundflower by typing:

sudo rm -r /System/Library/Extensions/Soundflower.kext

Once again, you will need to restart your computer for the changes to take effect.


June 11, 2009 | 7:36 am

On my computer, the finder info column shows: Version 1.4.3 and the about Soundflowerbed window shows: Soundflowerbed v1.1. ma++ ingalls|cycling74|2004-5 cycling74.com. It might be that just the About Soundflowerbed window needs updating. I have attached a screen dump showing the Finder and About windows. A low priority thing. The system is an upgraded (to dual 1.7 GHz PowerPC G4 MPC-7448) dual 800 MHz PowerPC G4 MPC-7450 Quicksilver running MacOS 10.4.11.


June 11, 2009 | 9:07 am

good spot – cheers


Viewing 6 posts - 1 through 6 (of 6 total)