Forums > MaxMSP

soundflower with max5 problem

October 15, 2008 | 1:34 pm

Hi List,

I’m having a problem using soundflower 1.2.1 with max 5, In max 4.6 if i set dsp status to

Audio – on
Driver – CoreAudio Built-in output
Input device – soundflower (2ch)
Output destination – Internal Speakers

I can route audio in and here it played back on the speakers of my macbook pro.

In Max 5 however the same settings do not route the audio in to max, to route the audio in I have to set the driver to Core Audio Soundflower (2) however this means I cant select my speakers as the output so I am unable to hear the audio.

Is this happening with anybody else

Cheers

JK


December 6, 2008 | 10:00 pm

I am having this same problem. Did you ever find a solution?

Thanks,
Zach


December 8, 2008 | 9:43 am

Sadly not, it seems really hit or miss, sometimes it will work sometimes it wont, it always works with max 4 though so I’m begining to think this is a max5 bug.


December 8, 2008 | 11:24 am

I don’t have have this problem with Max 5.0.5 and Soundflower 1.3.1.

You do know you can send Soundflower out to your speakers using Soundflower Bed? – just set 2 channels of SF to output on your speakers and then output to those channels in Max. You’ll need to use the 16ch driver to do this though if you want input from SF too.


December 8, 2008 | 5:23 pm

I was having the same problem, and I’m pretty sure it’s a Max 5 thing. If your on mac 10.4 or later (I think), you can get around the problem by making an aggregate sound device with soundflower and your internal speakers. Open up audio midi setup, click on Audio Devices. Then choose Open Aggregate Device Editor from the Audio menu. Click the button to add a new aggregate audio device, then check soundflower 2 channel and build-in output IN THAT ORDER. Now you have a new audio device with soundflower on channels 1 and 2 and mac output on channels 3 and 4 out. Now set the audio driver in the application from which you’re trying to route audio to be your new aggregate device. Also set the driver in Max to be the new aggregate device. You should be able to get sound into Max5 this way, and then play the sound out by setting your dac~ to channels 3 and 4.

Hope this helps.


December 9, 2008 | 12:42 am

say, could this be related to my using the M-Audio FW410 audio
interface? i’m happily working completely within max now, but i’m
curious for the future. do i need to aggregate the 410 into the
"Built-In" aggregate?
cheers
b

On Dec 8, 2008, at 12:23 PM, Sam Tarakajian wrote:

>
> I was having the same problem, and I’m pretty sure it’s a Max 5
> thing. If your on mac 10.4 or later (I think), you can get around
> the problem by making an aggregate sound device with soundflower
> and your internal speakers. Open up audio midi setup, click on
> Audio Devices. Then choose Open Aggregate Device Editor from the
> Audio menu. Click the button to add a new aggregate audio device,
> then check soundflower 2 channel and build-in output IN THAT
> ORDER. Now you have a new audio device with soundflower on
> channels 1 and 2 and mac output on channels 3 and 4 out. Now set
> the audio driver in the application from which you’re trying to
> route audio to be your new aggregate device. Also set the driver
> in Max to be the new aggregate device. You should be able to get
> sound into Max5 this way, and then play the sound out by setting
> your dac~ to channels 3 and 4.
>
> Hope this helps.

bruce tovsky
http://www.skeletonhome.com

"Sometimes the appropriate response to reality is to go insane."
Philip K. Dick


December 9, 2008 | 1:28 am

I’m having no problem to route a sound file playing in finder (or itunes) to route into max via soundflower 1.41 2ch, and then out to headphone. on os x 10.5.5.

i set my sound preferences to
INPUT: Line In
OUTPUT: Soundflower 2 ch

and max ezdac (on open message) setting to
INPUT: Soundflower 2ch
Output: Headphones.

works all well and easy, hope it helps.

jrp


December 9, 2008 | 3:15 am

Snowman,

I have been trying to implement your solution, but with no success. I created the aggregate device, with Soundflower 2ch and then built-in output as the configuration. I set the driver in the dsp settings of my adc~ as the new aggregate device, as well as the input and output setting in the sounds panel of the system preferences.

I set the input device in the dsp settings to the aggregate device (I wonder if part of the problem is that it won’t let me select an output device) and the input channels to 1 and 2. For output I have it sending channel 1 to channel 3 and channel 2 to channel 4. Do I need to select something different in the I/O mapping window?

Other than that the only setting I can think of are the speaker configurations in the audio midi setup. If I set them to Soundflower output, I get the data in Max and if I set them to stream 2 I get the sound. Also, when I have the data going into Max I am unable to even adjust the volume settings on my internal speakers. Any ideas what I’m doing wrong?

Thanks,
Zach


December 9, 2008 | 4:25 am

@Zach

So I’ve just re-tested the workaround, so I’m pretty sure it works. The problem isn’t that you can’t select the aggregate device as an output device. And no, with this setup, if you set the aggregate device as your default output, you won’t be able to adjust the volume on your internal speakers. In fact, the only way to adjust volume will be through Max. As I see, it, you could be doing one of three things wrong. In increasing order of likelihood:

1. You didn’t click on soundflower2ch and THEN built-in output. It’s essential that soundflower2ch get assigned to output channels 1 and 2, since most apps write to those channels by default and I don’t know of an easy way to change that.

2. You’re max setup isn’t right. I’m not sure what exactly you did in max, but you should do no more than open up DSP status, select the aggregate device both as your audio device and as your input device, then make an ezadc~ and connect it to a dac~ 3 4.

3. I’m pretty sure this is the problem: you have to set the aggregate device as the output device in System Preferences -> Sound, not in audio midi setup. I’m not sure what that does, if anything. I tried it and you’re right–it does let you get sound into Max, but you can’t hear it. So just leave the devices under System Settings in Audio Midi Setup on their defaults.

Hope that fixes the problem.


December 10, 2008 | 12:33 am

Snowman,

You’re totally correct, it’s #3. Thanks for the help!

-Zach


Viewing 10 posts - 1 through 10 (of 10 total)