Soundflowerbed stops on sleep

Jul 25, 2013 at 2:20am

Soundflowerbed stops on sleep

Hi, I am successfully running Soundflower 1.6.6b on Mountain Lion 10.8.4 except that if I put the Mac to sleep, when it wakes up again there is no sound because Soundflowerbed has stopped. It needs to be restarted from /Applications/Soundflower/Soundflowerbed.app – usually this is ok but sometimes the routing configuration has been lost and needs to be reset.

Has anyone else come across this – is it something wrong my end or a bug?

#257079
Sep 18, 2013 at 12:40am

Still no resolution of the problem. Doing a more thorough forum search I see that There is a longer thread with what may be a similar problem http://cycling74.com/forums/topic/soundflower-and-mountain-lion/ I have tried the workaround posted there with no luck. Also this is this thread where someone has created a fork which seems to address stability but is getting no response http://cycling74.com/forums/topic/modified-soundflowerbedimprove-stability-volume-control/

To summarize my problem…

After return from Mac OS X sleep occasionally soundflowerbed is working correctly, more often it is running but the Soundflower(2) output is not routed to any device (not even None) and most often the icon has vanished from the menu bar altogether and has to be restarted.

#265597
Sep 19, 2013 at 2:21am

Without meaning to state the obvious other users can have problems with Max if the computer go’s in sleep mode. Just disable sleep mode.
Compared to other programming problems this ones pretty easy to solve.
:)

#265701
Sep 19, 2013 at 4:03am

We are not talking Max here, but Soundflower. And Soundflowerbed is supposed to be running all the time. If it stops then ALL sound from the machine stops. Disabling sleep mode in this situation is disabling a useful feature of the machine so it not really a long term option.

#265705
Sep 19, 2013 at 7:07am

You could try using ‘Jack’ instead.

http://www.jackosx.com/

#265721
Sep 19, 2013 at 8:22am

Jack looks interesting but they seem to be having problems getting it to work with Lion and Mountain Lion (last update was Oct 2012).

I am also considering Audio HiJack Pro – it costs but the company have a good reputation.

#265729
Sep 23, 2013 at 12:32am

Hi – I have been testing the fork http://cycling74.com/forums/topic/modified-soundflowerbedimprove-stability-volume-control/ created by KYAB on 11 Jun 2013. I have had it running on my system for a week now and it seems to be stable – i.e. it fixes the problem that I originally reported where soundflowerbed drops out over an OS sleep.

Please can I encourage you cyclists to adopt at least the stability changes in this fork even if you don’t support he addition of the volume control (which I don’t use), to make the main line useable again.

Thank you.

#265959

You must be logged in to reply to this topic.