Forums > MaxMSP

Spat sound

April 10, 2009 | 9:25 pm

I can’t get any sound through Spat. I have included the file (I open with Max MSP 5) and a picture of my set up with all sound files operating. All other programs are sounding fine. Any ideas?

Many thanks
Regards
Steve


April 10, 2009 | 10:52 pm

Any message in your Max Window when you open your patch?


April 10, 2009 | 11:15 pm

It looks like your [Circ.3] isn’t found by Max (it has that pinkish background). I’m guessing that and the other necessary spat~ objects (that are inside those subpatchers) are not in the search path.


April 11, 2009 | 7:55 am

Jean-Francois Charles, There is no message in my Max window when I open my patch.
Roth, could you amend the patch and send it to me if possible?
Thanks.
Steve


April 11, 2009 | 10:00 pm

I have a feeling it doesn’t make a difference for your problem, but the picture you attached of a different patch that the one you attached to your first post.

steven.a.williams wrote on Sat, 11 April 2009 03:55
Jean-Francois Charles, There is no message in my Max window when I open my patch.

Notice the color in the background of your [Circ.3 source1 source2 source3] object in the picture you attached (until the next time I quote you I’m just talking about the picture, but similar things should apply to both)? That color means Max was not able to find the object needed. Seeing that makes me think you should at least be getting "newobj: Circ.3: No such object" in the Max window. I would expect if you open the patch in the picture you would actually get:

newobj: Circ.3: No such object
newobj: OPer-sel_late: No such object
newobj: Circ_Spat: No such object
newobj: Spat_Circ: No such object
newobj: Spat_Oper: No such object
newobj: Circ_Spat: No such object
newobj: Spat_Circ: No such object
newobj: Spat_Oper: No such object
newobj: Spat~: No such object
newobj: Spat~: No such object
newobj: Circ_Spat: No such object
newobj: Spat_Circ: No such object
newobj: Spat_Oper: No such object
newobj: Spat~: No such object

Check it again because the picture tells us Max can’t find all the objects it needs and if that is true you should get something in the Max window (incase you are new to all this, we don’t mean the patcher window, but the window you get by choosing Window > Max Window).

steven.a.williams wrote on Sat, 11 April 2009 03:55
Roth, could you amend the patch and send it to me if possible?
Thanks.
Steve

There is nothing wrong with the patch you attached, so there is nothing for me to ammend. Spat~ is a collection of abstractions and objects that work together (both for control and processing) to create the reverb. You attached one the tutorial files (a great thing to use until you decide to learn all the details to make your own spat~ patches), and these tutorials don’t do anything without the other objects.

The tutorials are in a folder called "tutorials" in a folder called "spat-3.4.1.1-forum" (or something like that depending on the version). In that folder you will find folders called "abstractions", "externals-osx", "init", etc. and Max needs to know how to find all the files in those folders for spat~ to work correctly.

You set what folders Max searches for files in by going to Options > File Preferences… where you can add search paths. Your main spat~ folder (e.g. spat~3.4.1.1-forum) should be in one of those locations or you can use that window to add your spat~ folder to wherever it is saved.


April 19, 2011 | 9:30 pm

You need to convert to max5 your abstractions. using Spat for Max5


Viewing 6 posts - 1 through 6 (of 6 total)