Forums > Jitter

spigot~ f***s up my video looping: jit.qt.movie: error parsing spigot~ cue data

June 27, 2011 | 7:16 pm

Hi, advanced users.

I’m very scared now because I made a search for the same topic and all of them have not answered. So, if this is a problem with no solution, please at least answer to me that it is so. then I can maybe just give up.

So, here’s my video playback patch. I get the impulse from supercollider to trigger the loop in jitter. I don’t think it’s the problem from that fact as the other player that also get triggered by supercollider via osc works well. (the other player uses "frame $1", jumping to frames at each triggering instead of loop.)

– Pasted Max Patch, click to expand. –

so, the problem is just that the looping is completely f***ed up. and it gets the famous error message. any solution for this? it’ll be really really really greatly appriciated…

thank you very much!!!!



pid
June 27, 2011 | 8:19 pm

is it an ‘@unique 1′ problem? just a quick thought.


June 27, 2011 | 8:51 pm

thanks for the answer,

I removed the ‘@unique 1′ attribute, but the problem continues…
any other ideas??

thanks


June 27, 2011 | 9:05 pm

spigot is a tough object to work with. Like me for example, I’m using max for live and when I switch videos in a patch that I made (using spigot) the sound of my movie is dropping (and it’s not suppose to)… This object needs work or I don’t know what because everybody who use it seems unsatisfied….


June 28, 2011 | 10:20 am

so….no solution? hmmm…

somehow I can’t believe there’s no solution for such a stupid problem.

it’s hilarious when I see all those tech-geeky talks and videos everyday on the web, kinetic, multi touch, vdieo mapping…bla bla. using max or whatever.
it gives you feel like we live in multi media heaven with full of possibilities and you can create ‘whatever you want’.

and the truth is, you CAN NOT even extract FUCKING AUDIO FROM FUCKING QUICKTIME MOVIE in real time just because it’s looping.
so, nothing to be excited about. all the fancy media art promo videos are made in order to sell ipads and one more copy of ableton lives, i guess.
the reality is that we can’t even do stupidest simple thing like this without becoming OpenGL expert or something.

…maybe it’s time to go back to VHS and cassette decks.



Jan
June 28, 2011 | 10:38 am

i never had this problem with spigot~ and your patch works fine in my setup…
but maybe you can achieve some improvements by playing around with your audio driver settings (latency, vector size etc…)

>>i guess. the reality is that we can't even do stupidest simple thing
like this without becoming OpenGL expert or something.

Certainly it is! and what is wrong about? If I want to become violin player it also includes several hours of practicing every day. My personal opinion is that craftsmanship is a value even though creation became partly digital.

..but I do have a lot of understanding for frustration ;)

cheer & heads up!

j.


June 28, 2011 | 1:51 pm

ok.

my conclusion is that spigot~ is too slow. it runs in control rate maybe.
as soon as I do something ‘extreme’, like stuttering or quick change of values, max crashes.

I don’t think there’s any solution instead change my whole set up, include my music, in order to use spigot~. but for now, I don’t want to.

but I hope that cyclin’ people develop a better, faster spigot~ for the future. It’s too attractive option to process video’s audio data in real time, to just forget about it…

thanks and cheers!



Jan
June 28, 2011 | 2:05 pm

i agree – would be great!
But taking into account that [jit.qt.movie] is simply a wrapper around the quicktime player provided by apple and not a player made by the cyclings themselves, i can imagine that there might be some limitations that are not on the max side but on the quicktime side (as this piece of software definitely never was developed to be very fast…. ;) )I

cheers!!


June 28, 2011 | 2:09 pm

Given that it works for Jan maybe you should examine the differences in your setups ie are you both on the same platform?

Also have you tried updating/downgrading quicktime?

Experimenting with different audio codecs/sample rates etc

Tried it on another machine?

Could you use soundflower to route the audio out from your quicktime movie and in to max again thus bypassing spigot? I dunno if its possible, just an idea.



Jan
June 28, 2011 | 2:35 pm

I am running on good old winxp sp3 and qt 7.6.9
But id didn’t put it into a "hard" speed test.


June 28, 2011 | 3:03 pm

well, it ‘works’.
but it doesn’t work ‘fast’.

but my setup is a bit hardcore for spigot~.

I get impulse from supercollider via osc and chops the video into 16 slices then rearrange it real time while getting slice positions through osc, then mix with above code play in sync with selected loop.

spigot~ isn’t fast enough to track and jump back and forth 100 different cue points in a second. that’s it. I do not think if I had better gears it will change the matter. it’s not about the cpu, it’s the object itself’s, or as jan pointed out, quicktime itself’s problem. for instance, supercollider can track and jump back and forth 100 different cue points in an audio sample a second, I think native msp object does too and jit.qt.movie also does when not attached to spigot~ and just output normal audio, for sure, no problem. it should be quicktime and spigot~ problem, because it’s not just audio sample or a video data, but something else…I guess it’s NOT AT ALL any set up, codec, power of the machine…etc. that will make the quicktime and spigot~ into different animal.

correct me if I’m wrong…

cheers,


June 28, 2011 | 3:58 pm

You are probably right about spigot. Maybe you need to use different tools?

I think I may have done a similar project though. I used Live for the audio portion and Vjamm or M4L for the video portion.

First I made a video slicer using drum racks in Ableton Live and Vjamm http://www.youtube.com/user/gavspav#p/u/9/LLTZhwCXgrU

Maybe more relevant is this MaxforLive video shuffler:

http://forum.ableton.com/viewtopic.php?f=35&t=132447&p=1058335&hilit=+video#p1058335


June 28, 2011 | 4:52 pm

thanks for the links.

the both looks interesting, but I do not have ableton live…

well, but surely there must be some solution elsewhere. I’m keep searching and will post here of anyone is interested…



pid
June 28, 2011 | 5:08 pm

i have ignored spigot~ ever since the troubles began when apple changed something in the qt codec(s). spigot~ worked fine years ago as far as i can tell. if you search these forums you’ll find age old discussions confirming this, including admittance from cycling folks (afaicr) of the problem. i don’t understand why everyone else doesn’t separately load video / audio into jit.qt and play~ respectively and sync the two at sample rate from your phasor~ and the frame message. or am i missing something really obvious here sorry?


June 28, 2011 | 7:10 pm

Although not necessarily the best way to do it (phasor~/play like pid mentions is probably better), I had the following patch laying around that does groove~/qt.movie syncing. Might be a starting point at least.

-Ben


June 29, 2011 | 1:49 pm

wow, thanks.

yes, it might be a solution since spigot~ seems to be very troublesome.
I get the pulse via OSC, maybe I should sync the sound with it, I’ll try and let you guys know.

thanks again for nice tip, cheers!!


September 27, 2012 | 11:07 am

has there been an update for this? or perhaps a demo patch that implements the play~ and phasor~ objects to control sync?


Viewing 17 posts - 1 through 17 (of 17 total)