spigot~ issue

Mar 20, 2007 at 6:56am

spigot~ issue

Hello -

I am working with a large QT movie that I am simply playing back. I would like to tap the audio of the movie using spigot~. I have run Tutorial 27 and have confirmed in a separate patch that spigot~ works as expected with the sample media in /patches/media. An export message appears in the Max window and the audio is routed into the MSP signal chain.

Unfortunately when I read my QT movie into the same jit.qt.movie object the soc parameter appears to be ignored. There are no export or error messages printed to the Max window. The audio is not routed properly to the spigot~ object.

I am wondering if the sample rate/bit depth of the audio media might be the issue. Here is the relevant info that appears in “get info” in QT Player:

24-bit Integer (big endian)
Stereo (L R)
48.000 kHz

The movie is just under 14 minutes long. The data rate is quite high, so posting it would not be practical.

Any suggestions?
Thanks, Jesse

#30924
Mar 20, 2007 at 2:14pm

How long did you wait before determining that it didn’t work? The
first time media is encountered, it has to be ripped to a temporary
file. 14 minutes could take a little bit of time.

jb

Am 20.03.2007 um 07:56 schrieb Jesse Gilbert:

> Unfortunately when I read my QT movie into the same jit.qt.movie
> object the soc parameter appears to be ignored. There are no export
> or error messages printed to the Max window. The audio is not
> routed properly to the spigot~ object.
>
> I am wondering if the sample rate/bit depth of the audio media
> might be the issue. Here is the relevant info that appears in “get
> info” in QT Player:
>
> 24-bit Integer (big endian)
> Stereo (L R)
> 48.000 kHz
>
>
> The movie is just under 14 minutes long. The data rate is quite
> high, so posting it would not be practical.
>
> Any suggestions?
> Thanks, Jesse
>
> –
> MacBook Pro 17″ 2GB RAM
> OSX 10.4.9
> Max/MSP 4.62
> Jitter 1.62
> QuickTime 7.1.5

#99579
Mar 21, 2007 at 1:48am

that was the problem – thanks Jeremy.

#99580

You must be logged in to reply to this topic.