Forums > MaxMSP

Stand alones / collectives – confusion and issues

July 11, 2006 | 5:13 am

hi everyone,

i’m trying to build a collective or stand alone (doesn’t matter to me which one), it’s the learning process that counts.

Here’s what i’m running into.

i get the can’t fragload jit.window…., can’t fragload jit.alphablend…. etc and I thought I’d been doing everything properly.

my script looks as follows:

open thispatcher

folder "Mortimer:/Library/Application Support/Cycling ’74/init/"
include "Mortimer:/Applications/MaxMSP 4.5/jitlib"
folder "Mortimer:/Library/Application Support/Cycling ’74/ad/"
folder "Mortimer:/Library/Application Support/Cycling ’74/jitter-externals/"

i’m building in Max 4.5, Jitter 1.5.2 on a PowerMac G4 running OSX 10.4.7

when I run the collective on a G5 running 10.4, i run into the problem stated where it can’t find the jit.window, etc. if i run it as a stand alone it’s fine.

When i test it on my older laptop (G4) running 10.3.9 as a collective or standalone, it can’t fragload the jit.window, jit.alphablend, etc…

My best guess is that as a collective and on the PowerMac running 10.3.9 it’s not loading jitter even though jitlib is built into the collective.

anyone run into these problems? any good solutions?

looking for that little thing that i haven’t come across or read in trying to figure it out.

thanks

-steve


check out my newest project and lend a hand (well a foot or two, really): http://www.shsarts.com/shoes
(now flavored with MySpace – http://www.myspace.com/shoe_project)

"I’ve never left the analog world, because there are processes unique to it that are not transferable to the digital world. I use them both."
– Gordon Mumma
———————–
Steven H. Silberg – light_painter@yahoo.com
AIM: Nsurface

http://www.shsarts.com


July 11, 2006 | 5:52 am

Check out Appendix D from the Jitter 1.5.2 Manual, but the basic
thing is that you don’t include jitlib with the build script, but
rather copy into the standalone’s package file.

-Joshua


July 11, 2006 | 1:23 pm

thanks..

doesn’t seem to make a difference whether i include it in the bulid or copy it to the standalone package. it appears in the package either way… whether i do it as part of the build or manually.

check out my newest project and lend a hand (well a foot or two, really): http://www.shsarts.com/shoes
(now flavored with MySpace – http://www.myspace.com/shoe_project)

"I’ve never left the analog world, because there are processes unique to it that are not transferable to the digital world. I use them both."
– Gordon Mumma
———————–
Steven H. Silberg – light_painter@yahoo.com
AIM: Nsurface

http://www.shsarts.com


Viewing 3 posts - 1 through 3 (of 3 total)