Forums > MaxMSP

Standalone app crashes on startup

December 3, 2012 | 1:34 am

Hello Friends,

I am having issues building standalone .app on 10.6.8 (Max 6.0.8). The built app crashes on startup about 30% of the time. I also tried building a simple patch with just a [standalone] object in it to eliminate any patch-specific issues – result is the same, built app crashes about 30% of the time.

I’ve tried the following:
- Deleted Max Preferences folder from Library.
- Did a full uninstall / reinstall of Max 6, as per the instructions in this post – http://cycling74.com/forums/topic.php?id=40492

Anyone else experiencing this issue? Any tips on how to resolve? I’ve attached the standalone patch and compiled app if anyone’s up for a quick try.

Many thanks!


December 3, 2012 | 1:52 am

What are the steps you’re doing to create the standalone app? You actually don’t need to have the standalone object in your patch. It just lets you customize it’s features.

GW


December 3, 2012 | 1:56 am

Here’s what I’m doing:

"Build Collective / Application"
openthispatcher option only
Select Application, give it a name
then Build.


December 3, 2012 | 2:01 am

Is there a crash report that you can upload?

GW


December 3, 2012 | 2:04 am

Of course, should’ve done that from the get-go! :)

Attached, and thanks for looking at this!


December 3, 2012 | 2:39 am

Hummmm….. could you build a basic patch with a counter or something simple. Build it as an application and post it here? The crash report is saying it has something to do with CFDictionary which shouldn’t have anything to do with the max architecture.


December 3, 2012 | 3:06 am

That was a basic patch generating that crash report – nothing but a [standalone] object in there with default options in Inspector.


December 3, 2012 | 9:30 am

Right, I understand that. But there could be something wrong with the app your creating and not inherent with the patch itself.


Viewing 8 posts - 1 through 8 (of 8 total)