Standalone App missing .class files

Mar 23, 2010 at 6:25pm

Standalone App missing .class files

I’ve been trying to build my patcher into a standalone application, and I keep having the same error. The Max window lists the following two errors repeatedly:

Could not load class ‘list.Replace’
Could not load class ‘list.Length’

To my knowledge, I’ve included all the java class files I need. I can’t even find a list.Length or list.Replace .class file. I can find List.class and Replace.class, but including them in the .app package makes no difference.

#49306
Mar 24, 2010 at 10:22am

did you put the .class files in the .app/Content/support/java/classes directory ?

#177171
Mar 24, 2010 at 3:13pm

Yes, any .class files I could find related to what I needed (like length.class or replace.class or some of my other .class files) were put into the .app/Contents/MacOS/support/java/classes directory, as I found in the documentation.

#177172
Mar 25, 2010 at 2:22am

Solved it.

I neglected to include the folder in which the ‘replace’ and ‘length’ class files were in, which was titled ‘list’.

If I included the ‘list’ director with these files as inside of the ‘class’ directory, Max was able to find them.

#177173

You must be logged in to reply to this topic.