Forums > MaxMSP

Standalone mess

April 11, 2006 | 10:51 am

Hi all,

Does anyone know how to make a Max standalone that works in every machine (Mac Os X.4)? I had a standalone that worked perfectly ok (I had Max 4.5 installed, anyway I thought that it wouldn’t matter because a standalone is supposed to stand "alone").

Apparently, it’s not quite so. Since I upgraded to Max 4.5.7, my app just started to report errors on startup (X# no such object, can’t fragload this and that).
I had the same problem when upgraded to Max 4.5. At that time, I reported this problem to the forum and Tim gave a solution (http://www.electrotap.com/blog/entries/00000055.shtml). Unfortunately, this trick is not working anymore.

This drives me nuts! A standalone should be _fully_ self-contained app!

Any help?

Thanks,

Carlos Caires

You can check my app at http://www.carloscaires.com (follow IRIN software)


April 11, 2006 | 11:57 am

Adenda:

I also tried to recompile my standalone from the original Max patches. No success either!

I get a strange looking Icon and it reports an error message ("YOU cannot open the application"" because it may be damage or incomplete")


April 11, 2006 | 12:05 pm


April 11, 2006 | 12:22 pm

Hello All,

Same here, LightRegie120x appears to work fine after a Combo update.

Philippe


April 11, 2006 | 12:36 pm

On 11-Apr-2006, at 13:57, carlosccaires wrote:

> I get a strange looking Icon and it reports an error message ("YOU
> cannot open the application"" because it may be damage or incomplete")

I had this a few times a year or so ago, tracked it down to not
completely following directions while building a standalone.

————– http://www.bek.no/~pcastine/Litter/ ————-
Peter Castine +–> Litter Power & Litter Bundle for Jitter

iCE: Sequencing, Recording & |home | chez nous|
Interface Building for |bei uns | i nostri|
Max/MSP Extremely cool http://www.castine.de

http://www.dspaudio.com/


April 11, 2006 | 12:42 pm

http://www.carloscaires.com loads a blank page, and Googling gets you a page that tells you "Irin Download is temporarily unavailable" – BUT the statement is in fact a hyperlink to download the software; is this some kind of Discordian trick ? ;-)
Anyway, apart from a slew of "coll: no file foo" messages, everything loads fine for me (OS 10.2.6, via combi update).
Nice looking interface, now where did those colls go…?
cheers
Roger


April 11, 2006 | 1:49 pm

On 11-Apr-2006, at 14:42, roger.carruthers wrote:

> http://www.carloscaires.com loads a blank page, and Googling gets you a
> page that tells you "Irin Download is temporarily unavailable" -

Worked fine here. OS 10.4.6, FireFox 1.5.0.1. StuffIt expanded fine
(although there has been a lot of argument in favor of moving to .ZIP
on OS X).

> Anyway, apart from a slew of "coll: no file foo" messages,

Since around Max 4.0 you can say [coll collname 1] to prevent the
"coll" no file" messages. Good idea for standalones.

————– http://www.bek.no/~pcastine/Litter/ ————-
Peter Castine +–> Litter Power & Litter Bundle for Jitter

iCE: Sequencing, Recording & |home | chez nous|
Interface Building for |bei uns | i nostri|
Max/MSP Extremely cool http://www.castine.de

http://www.dspaudio.com/


April 11, 2006 | 2:59 pm

Hi all,
I’ve run the 10.4.6 combo update and the problem remains.
I guess I’ll have to go back a few steps to figure out what’s going wrong. But it will have to wait … For now I’m too busy with my PhD thesis. Anyway, this version worked real fine, before those upgrades (Max and MacOs)…

The argument 1 for colls (not to look for a file) is not so good in my case because it also makes the data inside in not to be shared by other colls with the same arg (or via the refer message).

For those having problems accessing my website, try it with firefox.

Despite the "IRIN unavailability" on the dl page, the app is still there.
use this link if you want to check it out.

http://www.carloscaires.com/sw/IRIN.sit


April 11, 2006 | 3:35 pm

On 11-Apr-2006, at 16:59, carlosccaires wrote:
> The argument 1 for colls (not to look for a file) is not so good in
> my case because it also makes the data inside in not to be shared
> by other colls with the same arg (or via the refer message).

Works fine for me: share data among colls, no spurious "coll: file
not found" messages.

Good luck with the diss.

– P

————– http://www.bek.no/~pcastine/Litter/ ————-
Peter Castine +–> Litter Power & Litter Bundle for Jitter

iCE: Sequencing, Recording & |home | chez nous|
Interface Building for |bei uns | i nostri|
Max/MSP Extremely cool http://www.castine.de

http://www.dspaudio.com/


April 11, 2006 | 3:41 pm

>Coll [1]
You’re absolutely right. It works.
Thanks

C


Viewing 10 posts - 1 through 10 (of 10 total)