Startup Crash in Vista

Feb 9, 2007 at 1:30am

Startup Crash in Vista

Max runs fine, after install of Jitter program closes after booting up. Am Running on a brand new hp pavilion dv9000 vista supreme home edition. Any one else with this problem?

#30199
Feb 9, 2007 at 1:40am

probably not supreme enough if you don’t have quicktime installed?

On Feb 9, 2007, at 2:30 AM, Matt wrote:

>
> Max runs fine, after install of Jitter program closes after booting
> up. Am Running on a brand new hp pavilion dv9000 vista supreme
> home edition. Any one else with this problem?

#95986
Feb 9, 2007 at 2:10am

Quicktime is installed

#95987
Feb 9, 2007 at 3:53am

On Feb 8, 2007, at 6:10 PM, Matt wrote:

>
> Quicktime is installed

Next one on the list to check out is Java, and/or trying adding
jitter java-init 0; to a file named jitter-config.txt to prevent Java
from loading on launch. Search forums for more info or contact
support@cycling74.com.

If that still doesn’t work, I suppose OpenGL is worth investigating,
though it shouldn’t crash just on startup. Close to every problem on
application launch with Jitter on Windows (including XP) is related
to either QuickTime or Java.

-Joshua

#95988
Feb 14, 2007 at 12:03am

Didn’t they do something nasty to Open GL in Vista?

I haven’t been keeping up with it but i do remember a lot of gamers getting pretty animated about it. Possibly worth a search to see what you can come up with, after all the news on Vista changes from day to day and depends on who you ask.

Hope that helps,
John

#95989
Feb 14, 2007 at 12:08am

There was a whole stink about OpenGL being a second class citizen on
Vista, but the outcry caused MS to backtrack.

wes

On 2/13/07, john inder wrote:
>
> Didn’t they do something nasty to Open GL in Vista?
>
> I haven’t been keeping up with it but i do remember a lot of gamers getting pretty animated about it. Possibly worth a search to see what you can come up with, after all the news on Vista changes from day to day and depends on who you ask.
>
> Hope that helps,
> John
> –
> Imagination is more important than knowledge – A. Einstein
>

#95990
Feb 14, 2007 at 4:53am

Yes, I can confirm we have problems with Java in MaxMSP in Windows Vista. It affects all of our Java functionality. For now, you can put the line jitter java 0; inside a file named “jitter-config.txt” in the search path to disable Java in Jitter, and stay away from the mxj and mxj~ objects elsewhere.

We shall let you know as soon as we have it working.

-A

#95991
Feb 16, 2007 at 3:28pm

Hi, we’re having the same problem – and putting that message in a
file jitter-config.txt (in the “init” folder) comes up with an error
in the max window (right before crash) that says “Error: jit_kernel:
doesn’t understand java-init”. This is on Windows Vista, newest Max/
Jitter from the website (1.6.2).

thanks
evan

On Feb 9, 2007, at 3:53 AM, Joshua Kit Clayton wrote:

>
> On Feb 8, 2007, at 6:10 PM, Matt wrote:
>
>>
>> Quicktime is installed
>
> Next one on the list to check out is Java, and/or trying adding
> jitter java-init 0; to a file named jitter-config.txt to prevent
> Java from loading on launch. Search forums for more info or contact
> support@cycling74.com.
>
> If that still doesn’t work, I suppose OpenGL is worth
> investigating, though it shouldn’t crash just on startup. Close to
> every problem on application launch with Jitter on Windows
> (including XP) is related to either QuickTime or Java.
>
> -Joshua

#95992
Feb 16, 2007 at 5:11pm

On Feb 16, 2007, at 7:28 AM, evan.raskob [lists] wrote:

> Hi, we’re having the same problem – and putting that message in a
> file jitter-config.txt (in the “init” folder) comes up with an
> error in the max window (right before crash) that says “Error:
> jit_kernel: doesn’t understand java-init”. This is on Windows
> Vista, newest Max/Jitter from the website (1.6.2).

Put anywhere else in the search path besides init. Jitter is not
loaded at the point hat the init foder is read.

Sorry for the misinformation regarding the message. The message
should be “jitter java 0;”, not “jitter java-init;” The latter will
actually try to load jitter java support at a later point.

-Joshua

#95993
Feb 16, 2007 at 6:21pm

#95994
Feb 17, 2007 at 1:25am

I don’t actully have jitter yet so im not sure but i have had no problems with Max/Msp on Vista. I’m using vista xtreem which has got all he nastyness and resource hogging shite ripped out(also its only 350meg) so if a windows service is interfering with anything then it may not be in vista xtreem.

Also as you were sayingabout a OpenGl problem….would it be anything to do with the implimation of Direct X 10 drivers. Microsoft totatlly remade vista compared to XP so you never know what they messeda round with. eg the audio drivers have been taken out of the main kernel and made as a separate service in a UNIXesqe way.

I shall play around with different java stuff though to try and make it go wrong….its always fun to see what i can do to make windows crash

#95995
Mar 31, 2007 at 7:29pm

Hi guys,
I’am having the same problem. I’ve looked for the file jitter-config.txt but I can’t find it. Where it should be?
I used to have old version of max and jitter and it worked just fine on my system (I’m using vista), but then I downloaded the latest versions of max and jitter and it’s not working anymore.
thanks,
Itamar

#95996
Mar 31, 2007 at 9:04pm

There isn;t one. You have to make it. Put it in the same folder as
the Max config.

wes

On 3/31/07, Itamar wrote:
>
> Hi guys,
> I’am having the same problem. I’ve looked for the file jitter-config.txt but I can’t find it. Where it should be?
> I used to have old version of max and jitter and it worked just fine on my system (I’m using vista), but then I downloaded the latest versions of max and jitter and it’s not working anymore.
> thanks,
> Itamar
>

#95997
Mar 31, 2007 at 9:22pm

Hi wes,
I created a text file named jitter-config.txt and wrote inside “jitter java 0;”. the file is now in cycling74/java (in the same place as the max.java.config.
but still max/msp crashes at startup….
What shell i do???

#95998
Apr 1, 2007 at 11:47am

On 31 mars 07, at 23:22, Itamar wrote:

> Hi wes,
> I created a text file named jitter-config.txt and wrote inside
> “jitter java 0;”. the file is now in cycling74/java (in the same
> place as the max.java.config.
> but still max/msp crashes at startup….
> What shell i do???

Unless I’m missing something, it seems to be the java 1.6 issue, so
try this:
- in the “max.java.config.txt” file located in C74:/java/ change the
line “max.jvm.option -Xms16m” to “max.jvm.option -Xms64m”
- remove the jitter-config.txt
- start Max.

Cheers,
ej

#95999
Apr 3, 2007 at 3:22pm

i can confirm Emmanuel’s method, java works with vista/jitter

On 4/1/07, Emmanuel Jourdan wrote:
>
> On 31 mars 07, at 23:22, Itamar wrote:
>
> > Hi wes,
> > I created a text file named jitter-config.txt and wrote inside
> > “jitter java 0;”. the file is now in cycling74/java (in the same
> > place as the max.java.config.
> > but still max/msp crashes at startup….
> > What shell i do???
>
> Unless I’m missing something, it seems to be the java 1.6 issue, so
> try this:
> – in the “max.java.config.txt” file located in C74:/java/ change the
> line “max.jvm.option -Xms16m” to “max.jvm.option -Xms64m”
> – remove the jitter-config.txt
> – start Max.
>
> Cheers,
> ej
>

#96000
Apr 3, 2007 at 5:02pm

#96001
Apr 4, 2007 at 1:48am

Thanks Guys!
It was it. Now it finally working!
I really appreciate your help
Cheers,
Itamar

#96002

You must be logged in to reply to this topic.