Forums > MaxMSP

stop [poly~] voice windows opening?

January 22, 2012 | 12:24 pm

howdy fellow patchers,

as the title says i want to stop the opening of the [poly~] windows.
i have my object set as say [poly~ a.patch 16 args #0]. but it always opens the 16 voice windows, in the main patch with all the voices showing as well, how can this be stopped.
just would save a lot of time every-time i open my main patch that it did not happen.

cheers

lewis edwards
——
smokingbunny.co.uk


January 22, 2012 | 7:05 pm

You have saved the a.patch poly~ patcher with a window open. Open a.patch make sure all the windows associated with it are closed, save it, and the poly~ should load cleanly.


January 22, 2012 | 7:08 pm

that does not work for me, still the same problem of all voice windows opening

l


January 22, 2012 | 8:31 pm

post your patches, then


January 22, 2012 | 9:07 pm

Try closing all the windows, add a bang-object to the patch, delete it and save the patch. This worked(s) for me.

(the bang was random but just make sure something is changed in the patch before saving)


January 22, 2012 | 9:46 pm

if command-S depends on the dirty bit flag i would consider that a bug.


January 23, 2012 | 12:26 pm

still a probsem of it opening. even after doing the small change and saving thing.

im thinking of starting the patch again as a think it needs updating anyhow, just strange

l


January 23, 2012 | 7:41 pm

If you want other eyes on the problem, post your patches.


January 24, 2012 | 10:05 am

i cant really give the patch as it is for a client.
but i will just carry on, im more than sure that i will be able to solve the problem.

but thanks though for the help, if it carrys on with the new build im doing, youll know from me if tho problem happens again

l


January 24, 2012 | 10:34 am

Have you tried-

Ctrl-a,
Ctrl-c,
Ctrl-n,
Ctrl-v

(or the appropriate key if on mac) Copy everything into a new patch (including all the subpatchers/poly’s/whatnot)?

FRid


January 30, 2012 | 10:12 pm

seems i have found something to this problem

when i embed the bpatcher it opens all the voices, but when i unmark it, it does not open the windows

l


Viewing 11 posts - 1 through 11 (of 11 total)