storing dots- where have i gone wrong?

Jun 27, 2013 at 3:22am

storing dots- where have i gone wrong?

Hi,

Trying to store the dots on the matrixctrl. However, when patch is shut the dots disappear. I’ve attached what I’ve done to store them after shutting patch- where have I gone wrong please?

<code>

– Pasted Max Patch, click to expand. –

</code>

#254231
Jun 27, 2013 at 4:25am

This way ? u need to bang out that stored cells from your array (coll) first

– Pasted Max Patch, click to expand. –
– Pasted Max Patch, click to expand. –
#254236
Jun 27, 2013 at 5:25am

but this is not a good way of storing matrix data into coll ,as if you will provide more DOTS onto one column , your coll will store only the last DOT . as you are using matrix column index as a storing index in coll . you cant have more than one index of the same kind inside coll .

you need to figure out how to format that data to separate your index/column storage .

can you use Dict for it ? it might be easier perhaps .

#254246
Jun 27, 2013 at 5:34am

or with pattr ,

– Pasted Max Patch, click to expand. –
#254247
Jun 27, 2013 at 6:17am

pattr works well- thanks!

#254254
Jun 27, 2013 at 8:24pm

pattr and preset will both work with matrixctrl. if the dots are on/off (no intermediate stages) use preset, because there’s no extra file to deal with (unless you want to store additional banks of presets). If you want interpolation, like the matrixctrl cells represent volume levels or something, then use pattr.

#254331

You must be logged in to reply to this topic.