Forums > MaxMSP

Strange bug causing MIDI-choppiness

February 7, 2013 | 11:36 pm

I am experiencing a strange bug in Max 6.0.8 on OS X Mountain Lion. If I have "Scheduler in Audio Interrupt" on and I have a patch with both audio signals and midi cc control, after running the patch for some time (ca. 10 min but varies), MIDI gets extremely choppy, like having a very slow refresh-rate. When it occurs, ‘ctlin’ seems to output a value infrequently, like once or twice per second.

Toggling "Scheduler in Audio Interrupt" off and back on gets rid of the problem temporarily, but it comes back later. Sometimes the problem goes away otherwise as well, for example when a momentary CPU Overload occurs. Otherwise the problem doesn’t seem to have a relationship to CPU usage.

I recorded a short screencast to demonstrate the problem:
http://mutesrv.siba.fi/~vikuoppa/max/ -> "Max MIDI-jumpiness-bug.mp4"
In this example I’m moving two midi CC controls smoothly, but as can be seen on the sliders, the MIDI "refresh rate" is very slow/choppy. At 0:16 in the video I toggle Audio Interrupt off and back on, and this temporarily eradicates the issue as can be seen.

Technical details:
Computer:
MacBook Pro
15-inch, Mid 2012
Processor 2.6 GHz Intel Core i7
Memory 8 GB 1600 MHz DDR3
OS X 10.8.2

The issue happens with different audio interfaces – I’ve tested with RME Fireface 400, MOTU 828 and inbuilt audio. I have also tried changing the I/O Vector Size and Signal Vector Size, but the problem has occurred also with the different settings.

I didn’t notice this problem in Max 6 with my previous laptop (an older MBP), but have experienced it with different versions of Max 6 on this new laptop (at least also on 6.0.7).

Has anybody else encountered a similar issue? Does anyone have any suggestions I could try to get rid of the problem? I’m also happy to provide any further info or tests if somebody has some ideas. I’m playing a Max-based concert in a week’s time, so I’d greatly appreciate any help in solving this issue!

(I copied in the patch I used in the screencast, although there isn’t anything special about this patch as I get the problem with other patches as well…)

– Pasted Max Patch, click to expand. –

February 9, 2013 | 1:59 pm

Some additional info:
– Toggling "Vector Optimization" in Audio Status ON or OFF also temporarily fixes the problem. However, it will occur again after a while (i.e., it occurs irrespectively of Vector Optimization being on or off, but toggling it temporarily normalises the situation).
– According to my preliminary tests, I’m not getting this issue in Max 5, only in Max 6.


February 23, 2013 | 9:10 pm

Could someone with a similar configuration to mine (relatively recent MacBook Pro with USB3 ports running OS X 10.8) and with some kind of midi-controller with knobs or faders help me verify this bug? Cycling 74 has not been able to reproduce it and I haven’t had the chance to test it on a similar machine myself…


November 9, 2013 | 8:19 pm

I am also currently experiencing this exact problem. I have just recently started using audio signals to drive a sequencer and I believe audio interrupt must be switched on to work efficiently. Would anyone have any idea why the midi control gets ‘choppy’ after a short time? And also why toggling audio interrupt temporarily fixes the problem?


Viewing 4 posts - 1 through 4 (of 4 total)