Forums > Jitter

Strange shaders behaviour of tp.slide.jxs / cc.scalebias.jxs between max 5 & 6

August 19, 2012 | 7:23 pm

Good evening maxers,

I’m having trouble with tp.slide.jxs and cc.scalebias.jxs shaders combination.
I used it four years ago in a patch in order to draw with slow fade down. I used max 5 and it worked perfectly even if I used a veeeeeeery long fade down time…
Since then, I moved to max 6 and tried to reopen it few month ago, the fade out wasn’t working properly:
Over a certain amount of time (slide_down parameter = 114), the drawing won’t totally disappear.

I joined a test patch to that post, that would help you to understand and test between max 5 and 6…

Any help would be really appreciated, this is used in a 365 days/year running patch and I need to modify it…
Building an app on max 6 would be very nice due to the nice new features!!

Benoit.


August 24, 2012 | 6:56 pm

Hi,

I looked at it but I don’t understand why it’s not working either.

How about using the standard jit.slide object ?

– Pasted Max Patch, click to expand. –

August 24, 2012 | 7:31 pm

Hi,
Thanks for the feedback. I already tested jit.slide object but the slide down parameter has a too short effect.
Here’s two samples of use with the shaders:

Almost infinite time:

http://simon.ben.free.fr/CRAZY/video_test/crazy2.mov

Short time:

http://simon.ben.free.fr/CRAZY/video_test/crazy3.mov

Is someone from cycling has any idea of my solution?

Thanks again nimar.

Benoit.


May 23, 2013 | 7:48 am

Hi all,
I’m still bothered with this Max5/Max6 shaders topic. Can someone can have a look at it?
It would be VERRRRRY helpful.

Thanks a lot.

Benoit SIMON.


June 25, 2013 | 6:10 am

Hi all and Hi Benoit

i have the same thing and you know why Benoit
Nobody have a solution for that?
Thx for your response, you help us
Best regards

Alain Vétillard


June 25, 2013 | 11:30 am

AFAIK, this is a common issue with graphics apps, and is very display and GPU dependent.
one way i’ve overcome this in the past, is increasing the gamma attribute of jit.displays.

for what it’s worth, on my particular machine your patch works as expected, and the trails disappear even when i increase the slide parameter.


June 26, 2013 | 2:14 am

Thanks a lot Rob.
Can you please tell us the specs of your machine (at least your graphic cards)?

Benoit.


June 26, 2013 | 2:31 am

@Simon : I don’t get how your first patch could work as the flonum box isn’t linked to the slab sliding object… After adding an attrui, it works ok for me.

<code>

– Pasted Max Patch, click to expand. –

</code>

Edit @Simoon. Ooops sorry ! Going to have a look at it in the GL world…


June 26, 2013 | 2:55 am

@Stephane : You opened the NIMAR’s patch, not mine.
As I explained in my answer to NIMAR is that jit.slide has a too short trails.
If you have a better solution (in the GL world), I would love to test it.

Thanks.

Benoit.


June 26, 2013 | 3:41 am

@ Rob: Also, What I can’t understand is: why is it working on Max5 and not on Max6 on the same computer (same graphic card of course)

B.


June 26, 2013 | 5:26 am

@Simon : for me it works until I go beyond 150. with the flonum. Do you have the same result ?


June 26, 2013 | 5:42 am

@Stephane :110 for me


June 26, 2013 | 8:48 am

And btw works perfectly in max 5.19.


September 2, 2013 | 10:47 am

The tp.slide.jxs example works fine for me in max6, is that the case for you ? (jitter-examples > render > slab-helpers > temporal)


Viewing 14 posts - 1 through 14 (of 14 total)