Forums > MaxMSP

stupid error with Alt key for max help

March 31, 2006 | 9:46 am

I’m sorry to post here such a pity thing,, but it makes me mad really,,
,
I don’t know how come,, but it came from nothing,. when I press "Alt"
{MacOS} key to get some help patch in max,, it starts to write this
symbol: ] into it..,
I know that I can press Ctrl and than choose Help, , but I got so used
to it to get it this way,,
If you have any tip , , what his can be,, it’d be great to repair it,,.
Thanks a lot! ;]

pash*

- – - – - – - – - – - – - – - – - – - – - – - – - – - – - – -
my mom won’t swim without his suitcase
- – - – - – - – - – - – - – - – - – - – - – - – - – - – - – -
http://pash.tk
- – - – - – - – - -
- – - – - – - – - -
,


March 31, 2006 | 11:08 am

Perhaps you have a stuck key ? My Command key got stuck recently – freaked
the hell out of me trying to do stuff in Max, until I realised what it was!
A good blast of compressed air sorted it out; damn thing was full of
crumbs….
Moral: don’t eat & Max at the same time ;-)
Cheers
Roger


March 31, 2006 | 1:49 pm

I wist it was this.,. :D:D:D but my keyboard is only three weeks old, ,
so it’s clean as hell.,.
I reset all the keyboard pref in the system and it’s still the same.,. .
,.,.,
but thanks for the tip., ;] !!

pash*

- – - – - – - – - – - – - – - – - – - – - – - – - – - – - – -
my mom won’t swim without his suitcase
- – - – - – - – - – - – - – - – - – - – - – - – - – - – - – -
http://pash.tk
- – - – - – - – - -
- – - – - – - – - -
,


March 31, 2006 | 2:34 pm

On 31-Mar-2006, at 15:53, pash* wrote:

> I wist it was this.,. :D:D:D but my keyboard is only three weeks
> old, , so it’s clean as hell.,.
> I reset all the keyboard pref in the system and it’s still the
> same.,. .
> ,.,.,
> but thanks for the tip., ;] !!

For all of that, your symptoms indicate that some non-modifier key is
being pressed whenever you press the option key (PCs have alt keys,
Macs have option keys, btw).

Suggest following: go to System Preferences, select International,
Input Menu pane, activate Keyboard Viewer from the list of keyboard
layouts. While you’re there, turn on Show Inputer Menu in Menu Bar
(from the bottom of the window). Then go to Max, select Keyboard
Viewer from the Input menu (right of Menu Bar, you’ll see a little
flag, probably Stars & Stripes). Watch the viewer, it will show you
what keystrokes the hardware is really sending to the computer.

Good luck,
P.

PS: Keyboard Viewer is one of the most neglected handy utilities
Apple ever produced, although the OS X versions seem a little flakey
compared to what we had from Finder 1.0 through to OS 9.2.x.

————– http://www.bek.no/~pcastine/Litter/ ————-
Peter Castine +–> Litter Power & Litter Bundle for Jitter

iCE: Sequencing, Recording & |home | chez nous|
Interface Building for |bei uns | i nostri|
Max/MSP Extremely cool http://www.castine.de

http://www.dspaudio.com/


March 31, 2006 | 4:00 pm

OK, this is the second time I’ve read this in as many weeks, and I’ve
got to step in. Peter, you have lived in .de for long enough to have
seen a German Mac keyboard — mine says "alt", so let’s just leave those
hegemonic key-cap presumptions at the door and give the poor guy a break.

I can supply a photo if necessary.

jb

Am 31.03.2006 um 16:34 Uhr schrieb Peter Castine:
> (PCs have alt keys, Macs have option keys, btw).


March 31, 2006 | 5:47 pm

hello!
thanks for reall care,, but my keyboard isn’t german,,, , I have Czech
one.., {maybe you remember me from your workshop at FAMU for M.
Vojtechovsky, I had a lot of questions about cv.jit etc.,,}.., and it’s
strange, because it used to work,, ,
I hope that I don’t make blind alarm and that it’s not my misknowledge of
mac os,, but as I said, , all the keyboard prefs are already reset..,.

thanks a lot for any help!

max for fun,, max for ever!

pash*

= = = = = = = = = = = =

On Mar 31, 2006, at 6:00 PM, Jeremy Bernstein wrote:

OK, this is the second time I’ve read this in as many weeks, and I’ve got
to step in. Peter, you have lived in .de for long enough to have seen a
German Mac keyboard — mine says "alt", so let’s just leave those
hegemonic key-cap presumptions at the door and give the poor guy a break.

I can supply a photo if necessary.

jb

Am 31.03.2006 um 16:34 Uhr schrieb Peter Castine:
(PCs have alt keys, Macs have option keys, btw).


March 31, 2006 | 5:58 pm

nop.,.

I’m really sorry,, , but I guess that it’s something in the system,,
because it changes behaviour when i swich keyboards {i mean
languages}..,.,

so forget my post,. this has nothing to do with max.,.,

thanks anyway !

pash*


March 31, 2006 | 6:32 pm

On 31-Mar-2006, at 18:00, Jeremy Bernstein wrote:
> OK, this is the second time I’ve read this in as many weeks, and
> I’ve got to step in. Peter, you have lived in .de for long enough
> to have seen a German Mac keyboard — mine says "alt", so let’s
> just leave those hegemonic key-cap presumptions at the door and
> give the poor guy a break.

OK, I may be being a bit retentive on this. But your keycaps have the
‘alt’ in small italics at the top, originally put there for people
using SoftPC & Co. The "official" name of the key is given by the
bathtup symbol at the bottom of the key, which is the intergalactic
sign for "Wahltaste".

At least it used to be. Look, DDZ calls me anal-retentive, so feel
free to do so as well.

I’ve got five Apple keyboards lying around the room: US, .DE,
"Int’l". But, sure, send me a picture if you like. Just don’t post it
to the forum;-)

Take care…


March 31, 2006 | 6:50 pm

Dobrý den, Paš !

On 31-Mar-2006, at 19:58, pash* wrote:
> I’m really sorry,, , but I guess that it’s something in the system,,
> because it changes behaviour when i swich keyboards {i mean
> languages}..,.,

I still think it’s your keyboard. I just switched to Czech and option-
clicked on various objects in Max and everything worked as expected.
Mac OS 10.4.5, Max/MSP 4.5.6.

However, Max may not be entirely international-keyboard friendly and
switching to US keyboard layout is possibly the most reliable thing.
For instance, I could not get a message box or comment to accept
haček-marked letters even when using Czech keyboard and changing to a
Unicode-capable font like Lucinda Sans.

Good luck, anyway.

– Petr

(Ne, nemluvim česky dobře, alle resumim trošičku.)


March 31, 2006 | 10:18 pm

Peter Castine wrote:
> (PCs have alt keys, Macs have option keys, btw).

Things seem to have changed, my Powerbook says alt on its option key…

I guess if its printed on it, its an alt key, but where the hell is the
option key then :-()

Stefan

[][] [][][] [][] [][][]
[][][][][][][][][][][][][][][]

Stefan Tiedje
Klanggestalter
Electronic Composition
&
Improvisation

/~~~~~
\ /|() ()|
))))) )| | |( \
/// _/)/ )))))
___/ ///

————————-x—-
–_____———–|———–
–(_|_ —-|—–|—–()—-
– _|_)—-|—–()———–
———-()————x—–

14, Av. Pr. Franklin Roosevelt,
94320 Thiais, France
Phone at CCMIX +33-1-57 42 91 09


April 1, 2006 | 1:12 am

mine says both.

does that mean its "confused"? should I bring my powerbook in for
counseling?

;)

v a d e //

http://www.vade.info
abstrakt.vade.info


April 1, 2006 | 7:24 am

On 31.3.2006, at 16:34, Peter Castine wrote:

>
> Suggest following: go to System Preferences, select International,
> Input Menu pane, activate Keyboard Viewer from the list of keyboard
> layouts. While you’re there, turn on Show Inputer Menu in Menu Bar
> (from the bottom of the window). Then go to Max, select Keyboard
> Viewer from the Input menu (right of Menu Bar, you’ll see a little
> flag, probably Stars & Stripes). Watch the viewer, it will show you
> what keystrokes the hardware is really sending to the computer.
>

yep,,, so this answered all questions,, when i take a look at keyboard
viewer,, alt {on my keyboard its really named alt ;], pwb 1,67} never
ge pressed,, when i press the button viewer acts like that the button
for " ] " is pressed,,. . so now i’m looking for help in mac forums.,.
but thanks a lot!!

On 31.3.2006, at 20:50, Peter Castine wrote:

> Dobrý den, Paš !
>
> I still think it’s your keyboard. I just switched to Czech and
> option-clicked on various objects in Max and everything worked as
> expected. Mac OS 10.4.5, Max/MSP 4.5.6.
>
> However, Max may not be entirely international-keyboard friendly and
> switching to US keyboard layout is possibly the most reliable thing.
> For instance, I could not get a message box or comment to accept
> haček-marked letters even when using Czech keyboard and changing to a
> Unicode-capable font like Lucinda Sans.
>
> Good luck, anyway.
>
> — Petr
>
> (Ne, nemluvim česky dobře, alle resumim trošičku.)

Ahoj! :D

i’m not using czech keyboard very often…, not at all in max.,. :D
but it’s fun to meet someone on the forum who speaks it at least little
bit! ;] {but trully it seems that you speak more than trosicku!!}

Tak dekuju!! A krasny den!

pash*

- – - – - – - – - – - – - – - – - – - – - – - – - – - – - – -
my mom won’t swim without his suitcase
- – - – - – - – - – - – - – - – - – - – - – - – - – - – - – -
http://pash.tk
- – - – - – - – - -
- – - – - – - – - -
,


April 1, 2006 | 9:57 am

On 1-Apr-2006, at 0:18, Stefan Tiedje wrote:
> Things seem to have changed, my Powerbook says alt on its option
> key…

The keyboard I’m typing on was delivered from the Apple Store in Cork
less than a month ago. It still has the Intergalactic Sign of the
Option Key clearly printed on it.

‘Alt’ is also printed on it at the top in smaller letters, just as
‘delete’ is printed on the Forward Delete key, which has the
Intergalactic Sign for Forward Delete at the bottom left. Note that
the bottom left is where all the other keys have their "normal
usage" labels printed. Top left and small is for "alternate names
when using emulators for terminals and/or other operating systems."

– Mr. iLaF


April 1, 2006 | 12:49 pm

On all my apple keyboards, the relevant key has ‘alt’ at the top, and
at the bottom a totally incomprehensible symbol – This way to the
underpass? The surfer has come off the wave? – by no conceivable means
could it suggest to me the word "Option"! ;-)>

Lawrence

Lawrence Casserley – lawrence@lcasserley.co.uk
Lawrence Electronic Operations – http://www.lcasserley.co.uk
Colourscape Music Festivals – http://www.colourscape.org.uk


April 1, 2006 | 2:26 pm

On 1-Apr-2006, at 14:49, lawrence casserley wrote:
> the relevant key has ‘alt’ at the top, and at the bottom a totally
> incomprehensible symbol

Exactly: the Intergalactic Sign of the Option Key.

Sheez, has *no one* on the list seen _Mars Attacks_???


April 1, 2006 | 2:46 pm

shift, control, alt, super, hyper, meta, and bollocks.
What’s the problem?


April 1, 2006 | 6:39 pm


April 1, 2006 | 6:47 pm

I have to say I find this slightly more delightful, but just by a hair.

jb

Am 01.04.2006 um 20:39 Uhr schrieb Peter Castine:
> Anyway, folks’ll prob’ly now be delighted to see me plugging Litter
> Power rather than being a pedantic piece-of-alliterative-anatomy
> about naming keystrokes. I’m prepared to drop the subject.


April 1, 2006 | 8:11 pm

Ah well – I’ve always seemed to have more interesting things to do with
my life than to delve into these arcane depths. I still think the
symbol is impossibly obscure, though.

I prefer, "Danger steep hill – oh, too late!" No options there!

I hope soon you will find the option to think about more alternative
things! ;-)>

With very best wishes for your health and security

Lawrence

Lawrence Casserley – lawrence@lcasserley.co.uk
Lawrence Electronic Operations – http://www.lcasserley.co.uk
Colourscape Music Festivals – http://www.colourscape.org.uk


April 3, 2006 | 8:54 pm

Peter Castine wrote:
> the cloverleaf is presumably recognized by most as the
> Command Key (sometimes referred to as the "Apple" key, but not in any
> Apple documentation I’ve seen since Jobs killed Lisa).

I consider the printing on the keyboard itself the most obvious Apple
documentation available, the only one everybody (but Peter) reads. The
documentation Peter reads is widely unknown to most people. And now read
the documentation on your keyboard: The symbol right beneath the
cloverleaf (Command Key) is a very recognizable symbol even kids would
be able to give the correct name — you got it — Apple.
This seems to be a conspirative hidden "Wink mit dem Zaunpfahl" to
confuse insiders… Lisa is dead, long live Lisa ;-)

Stefan

[][] [][][] [][] [][][]
[][][][][][][][][][][][][][][]

Stefan Tiedje
Klanggestalter
Electronic Composition
&
Improvisation

/~~~~~
\ /|() ()|
))))) )| | |( \
/// _/)/ )))))
___/ ///

————————-x—-
–_____———–|———–
–(_|_ —-|—–|—–()—-
– _|_)—-|—–()———–
———-()————x—–

14, Av. Pr. Franklin Roosevelt,
94320 Thiais, France
Phone at CCMIX +33-1-57 42 91 09


Viewing 20 posts - 1 through 20 (of 20 total)