subpatcher not playing at the same time as main patcher

Apr 10, 2013 at 5:53pm

subpatcher not playing at the same time as main patcher

I’ve got two synths running at the same time. One is from the main patcher window and one is from the subpatcher “p harmony”. Sometimes they are both running and sometimes only one of them will run or the other one will start playing randomly. I want them to both play at the same time all the time. What should I do ?

– Pasted Max Patch, click to expand. –
#67650
Apr 10, 2013 at 6:32pm

In the harmony subpatcher, do you want the 250 message to go into the right side of your metro? In the left, it just turns on the metro but doesn’t set anything. You might also be having troubles with the toggle state in your subpatch.

#243403
Apr 14, 2013 at 2:36pm

you’re right about the 250 message. fixed that and the toggle state in the subpatch. the subpatch seems to be playing just fine but the main patcher randomly stops playing and then starts again just as randomly. the bangs are triggered by the metro but there’s no sound coming out.

#243404
Apr 14, 2013 at 4:51pm

The next thing that jumps out at me is that you’re sending two integers into makenote almost simultaneously. makenote can only manage one note at a time, so you probably want one makenote for each pitch that you want to here.

I find the signal flow in your patch hard to follow. In general, a straight flow from top-to-bottom is easier to follow. Take out any non-functional elements of your patch and try to isolate the bug with the smallest number of objects possible.

#243405

You must be logged in to reply to this topic.