Suppressing Max Window display on standalones

Jan 21, 2010 at 6:30pm

Suppressing Max Window display on standalones

Does anyone know how you suppress the Max window from appearing automatically when you run a standalone generated from your patch?

#47889
Jan 21, 2010 at 6:38pm

Ahh, found it. I didn’t see the inspector option for [standalone] at first. I realise now it’s called the status window :)

#172224
Jan 21, 2010 at 6:42pm

You can use [standalone ]. It has an option to suppress the status window (Max window) at startup. You could then use [menubar ] to remove the option to open the max window from the munu in your application. I’m not sure exactly how or if it would be neccessary, but you could probably modify one of the json files (dunno which one) in the contents of your app to remove the keyboard shortcut that opens up the max window.

#172225
Jan 21, 2010 at 6:42pm

too late haha

#172226
Jan 21, 2010 at 7:06pm

There appears to be something wrong on Windows.

I’ve built my patch for both Windows and OS X.

I’ve used the [standalone] option to disable the status window on startup for both.

On OS X, it’s fine – it opens without the Max window.

On Windows, it always opens with the Max window.

Any ideas?

#172227
Jan 21, 2010 at 8:11pm

OK, I’ve answered my own question.

If you execute a ‘window flag nomenu’ then the Max Window will open even if it is disabled in the [standalone] object inspector.

Eddy

#172228

You must be logged in to reply to this topic.