sychronizing MSP with Logic

May 3, 2006 at 10:12am

sychronizing MSP with Logic

has anyone ever tried doing synching the transport in
logic to the play position in a MAX MSP sequencer?

experimenting with hostsync~ hostphasor~ have not
given me good results

any ideas?

i already posted this 4 times

please help!

james

NEW Yahoo! Cars – sell your car and browse thousands of new and used cars online! http://uk.cars.yahoo.com/

#25755
May 3, 2006 at 10:56am

> has anyone ever tried doing synching the transport in
> logic to the play position in a MAX MSP sequencer?
>
> experimenting with hostsync~ hostphasor~ have not
> given me good results

host/plug phasor~ from Logic Audio is Jittering a lot, i think it’s Logic’s fault :(

What is the problem with hostysync~ ?

> any ideas?

you could also build a pluggo using the pludsync~ object, and then send the sync messages over local network using mxj net.maxhole or another network protocol.
I’ve had great success with this method… if you do the pluggo as a plugin you can also transmit midichannels, and even better.. it doesen’t have to be on the same computer…

> i already posted this 4 times
>
> please help!

if you wan’t any real help, you could post an example of your sync method ? or be more specific about what the problem is ;)

#76201
May 3, 2006 at 6:57pm

hi

hostphasor~ seems fairly stable to me so far

I’m using OS 10.3.9 and Logic Gold 6.3.1.

the problem I’m having is with both hostsync~ and
plugsync~.
neither gives an accurate transport position. If I
make a loop in Logic , between ,say, bar 3 and 4, the
value from hostsync~ or plugsync~ loops too early,
from about 2.9 to 3.9. Its more innacurate at faster
bpms.

consequently i can’t reliably sync logic and max
together to a specific point in a timeline

any help appreciated

james

#76202

You must be logged in to reply to this topic.