Forums > MaxMSP

synched buffer recording

February 19, 2009 | 10:44 am

Hello.

In the continued absence of >4ch [buffer~]s (with 5.1, 7.1 etc I
remain surprised and a bit frustrated at this), I’m trying to find a
means of sample-accurately synching the transfer of an 8ch file to two
4ch [buffer~]s. I’ve tried the following which isn’t successful.

I’m assuming that two simultaneously-triggered (control domain)
[record~] objects wouldn’t be reliably synchronous?

There’s probably an easy solution for this, but I’m a bit stumped.

Would be grateful for assistance.

pete.

– Pasted Max Patch, click to expand. –


zoe
February 19, 2009 | 11:19 am

Sorry to answer with another question, but i wonder if a solution like send your signals in 8 record~ objects, and starting the recording with sending a 1 simultaneously to all of them would make them start the recording at exactly the same time (sample-accurately)???


February 19, 2009 | 3:28 pm

Thanks for your response, Zoe. I’d thought about using [record~] in
that way but am not confident that a 1 sent to both in the control
domain would trigger them sample accurately and in sync. It certainly
doesn’t when simultaneously triggering two [groove~] objects.

I’m getting round the problem of syncing playback from my two 4ch
[buffer~]s via a cludge: controlling two 4ch [play~] objects with the
sync output from [groove~]. Complicated and inefficient cpu-wise but
it seems the only way to have more control over pitch shift over time
([line~] and [curve~] don’t offer enough control).

If anyone has a better idea re this latter aspect too I’d appreciate
any thoughts…

Thanks again.
pete.

On 19 Feb 2009, at 11:19, zoe de lukaas wrote:

>
> Sorry to answer with another question, but i wonder if a solution
> like send your signals in 8 record~ objects, and starting the
> recording with sending a 1 simultaneously to all of them would make
> them start the recording at exactly the same time (sample-
> accurately)???


February 19, 2009 | 3:41 pm

>It certainly
doesn’t when simultaneously triggering two [groove~] objects.

Did you try with the "scheduler in audio interrupt" option on?

p


February 19, 2009 | 3:43 pm

>It certainly
doesn’t when simultaneously triggering two [groove~] objects.

Did you try with the "scheduler in audio interrupt" option on?

p


February 19, 2009 | 5:35 pm

Try index~ with count~. You are certain of the sync that way.

I have to say that scheduler in audio interrupt works fine for me.

pa


Viewing 6 posts - 1 through 6 (of 6 total)