Forums > MaxMSP

Syncing multi-channel audio with QT video

August 20, 2010 | 9:52 pm

What would be the best way to go about ensuring my audio stays synchronised with my QT video?

I have a 4-channel sound file playing through an ‘sfplay~ 4′ object. I trigger this to play at the same time as the ‘jit.qt.movie’ object but they do not stay perfectly in sync. It particularly becomes problematic as they loop around and repeat several times.

Is there any better way I could go about doing this?

Thanks.



FP
August 21, 2010 | 11:38 am

why don’t you embed the 4 tracks in the qt movie file ?


August 21, 2010 | 1:19 pm

Well i’m using Adobe After Effects to make the video and this only gives options for mono/stereo audio. Is there a way to embed 4-channel audio into a qt file?
And will ‘jit.qt.movie’ know to send those to the right channels? There doesn’t seem to be many options relating to audio in the help file.



FP
August 21, 2010 | 1:30 pm

yes no problem. you know, qt is very powerful.
you can add audio and route channels inside qt (with the pro version, i suppose).

no problem after that to read the file with proper routing.

i do that with fullHD video with 8 audio channels.

i don’t excatly remember but i suppose you can add 24 audio channels.


August 21, 2010 | 2:21 pm

Great. Ok i’ll get quicktime pro then and try this out.
Thanks.


August 21, 2010 | 4:26 pm

Ok I made a qt file with 5.1 sound and played it in Max using ‘jit.qt.movie’ but all the channels were just mixed together and played out the stereo left and right.
How do you make the object route audio correctly for multi-channel audio?



FP
August 21, 2010 | 5:18 pm

ctrl-J in QT. and set the audio parameter (routing, etc)


August 21, 2010 | 5:26 pm

Yeh i’ve done that. But when I open it in Max and play it using jit.qt.movie it just seems to sum the whole mix and play them as a stereo file. Are you doing anything else in Max that allows it to route the channels correctly?



FP
August 21, 2010 | 5:48 pm

normally you have nothing to do in max because you’re using the quicktime engine.
when you play this file just in qt, is it ok for audio in you soundcard ?

when you play it in max, be sure you’re using a multitrack soundcard.


August 21, 2010 | 9:04 pm

Yeh i’m using a soundcard with multiple outputs but even in Quicktime it is all just going to stereo.
It appears to be set up correctly in the Movie Properties section.
It is a 6 channel (5.1) WAV file that I have embedded with the video. Should this be a different format (ac3 or something)?

Thanks.



FP
August 21, 2010 | 9:38 pm

no, the format (6 channels embeded wave) is perfect.

audio settings have to be : l, r, lfe, c, left surround, right surround.

maybe if you use apple check your audio configuration. and be sure you are using your soudcard as output.

what is your configuration (os, soundcard) ?



FP
August 21, 2010 | 9:49 pm

you can check this : http://pan-etc.net/res/media/fp/test-surround.mov

it works for me. so…


August 21, 2010 | 10:22 pm

Your right, it was the routing in quicktime. It looked like it was set up properly because it said left, right, centre, etc. but actually I had to change them to ‘Discrete-0′, ‘Discrete-1′, etc. and now it works.

Thanks very much for the help.


June 16, 2011 | 10:28 am

hi fp,
could you please repost your quicktime? i am testing a similar setup, and it would be real nice to have a reference movie.
best,
/j


Viewing 14 posts - 1 through 14 (of 14 total)