Forums > MaxMSP

Syncing multiple audio channels to video

May 2, 2010 | 7:11 am

Hello,

I am assembling a multichannel video installation using Zach Poff’s Multiscreener patch. I’m fairly new to the max/msp/jitter world, so any help you can offer would be most appreciated.

The patch I’m using can be found here:

http://www.zachpoff.com/site/software/software.html

Right now I have two videos displayed over six television sets using 2 mac minis and 2 Matrox triplehead2go graphics expansion modules. The two videos sync perfectly with the multiscreener patch, however I would like to send individual audio tracks to their corresponding monitors.

I have a Presonus Firestudio firewire audio unit that will allow me to send the 6 separate audio channels to their corresponding television set. What I am looking for the best/easiest way to sync these audio tracks to the videos.

I have been searching the forum, and think my answer might be to export the 6 audio channels as separate aiff tracks, and use sfplay to play the audio files individually.

I was thinking there must be a way to get sfplay to read and sync to the timer of the multiscreener server patch, but am at a loss on how to actually do this.

Again, any help would be much appreciated.
Thanks in advance,

Dustin


May 3, 2010 | 8:15 am

I’m not sure it is the same problem but…
A few month ago I had to do a patch that plays qt videos with 4 channels audio.
I was also thinking about having the 4 channels as separate files and play them with sfplay~, but finally the (easy) solution was to export the videos with the 4 channels included (with Final cut pro or soundtrack, I don’t remember)
Then, no need for anything, qt just played the video and 4 audio channels.

By the way, thanks for sharing these patches, they are great !

Yoann


May 5, 2010 | 12:57 am

Thanks for the advice. Pulling the multiple channels from the quicktime file would definitely be the easiest way for me to accomplish this. However jit.qt.movie doesn’t seem to want to separate the audio channels. It just combines them all and sends them out of all the outputs.

I know the separate channels are all there. When I reimport the .mov to Final Cut Pro, the six distinct channels show up on the timeline. DSP recognizes my audio card, as I can get (dac~ 1 2 3 4 5 6) to send audio signals to the separate outputs.

Any suggestions on what I can do to get jit.qt.movie to recognize the separate audio channels?


Viewing 3 posts - 1 through 3 (of 3 total)