text3d-matrix-fsaa problem

Jan 20, 2014 at 12:16am

text3d-matrix-fsaa problem

Hey everybody

First I have to say that (due to insufficient funds) I’m still working with Max 5.

I want to multiply the output of a jit.gl.render (which renders a 3d text) with a video. Therefore I route the render object and the video both through matrices and multiply those. Now i found that the fsaa in the jit.window object has no effect on the text anymore, as soon as you put a matrix between the jit.gl.render and the jit.window. Without the matrix in between the antialiasing works fine. I can post a patch which shows this problem if it’s required.

I’ve also tried to solve the problem by using the jit.gl.slab object to multiply the two components, which would have the nice side effect of relieving my cpu. But I did not manage to route the output of the jit.gl.render to such an object (also in the examples this object seems to occur only in context with quicktime movies, not with jit.gl objects).

I am very grateful for any help. Thanks in advance.
Sandrew

#278637
Jan 28, 2014 at 1:25am

Anybody?

#279318
Feb 3, 2014 at 1:01pm

you should use a jit.gl.videoplane to display your movie, and blend with the gl.text in gl land.
post a patch showing what you’ve tried, if you need more info.

#279997

You must be logged in to reply to this topic.