textbutton causes fatal crash when saving preset

Dec 1, 2013 at 6:15pm

textbutton causes fatal crash when saving preset

Is there anyone who can say this doesn’t happen and it’s just me? I tried making a patch with nothing but a preset and textbutton object now, just to be sure. After saving a preset, Max crashes so bad I have to reboot.

This has been true since at least Max v6.03, and I thought it would get fixed eventually, but it’s still happening. Maybe it’s just me, but it seems a rather fundamental problem.

#274336
Dec 1, 2013 at 11:54pm

cant reproduce here (max614-osx1068)
although i do sometimes have nasty things which seems (according to crashlogs) to be caused by a textedit button, in a patch with opengl jitter (unreproducable)

#274350
Dec 2, 2013 at 1:22am

Thank you, that helps isolate the problem. Could it be a bug with Windows 7? I have had the problem on both 32-bit and 64-bit versions of Windows 7.

#274355
Dec 2, 2013 at 3:49am

hi, I’m getting problems with saving a preset if there’s a filtergtaph in the same patch, I’ve built test patchers to try all additions until adding a filtergtaph and then trying to save a preset causes a crash…

i know not exact same issue as you but i’m wondering if theres a bug in the preset in current builds?

best of luck

#274364
Dec 2, 2013 at 7:44am

Hmm. I forgot to mention it is with textbutton in ‘toggle’ mode that is causing a crash. I tried this in Max 6.03, 6.05 on 32-bit Windows 7, and on 6.12 and 6.15 in 64-bit Windows 7. At first I thought it was me was doing something wrong, then I made a patch with nothing but a textbutton in toggle mode and a preset object. Shift-clicking on the preset caused the crash. I never tried with filtergraph.

#274383

You must be logged in to reply to this topic.