texture with alpha channel and gridshape

Jan 26, 2013 at 4:44am

texture with alpha channel and gridshape

i was trying to solve this in the last few hours, browsing the forum, but i couldnt…

all i would like is to map a PNG file (with alpha chanel included) to a gridshape (plane) and see throught the holes where alpha is totally transparent and don’t see throught where i dont have the alpha mask… i can make the texture transparent, but can’t make the alpha channel working in the PNG file…

first i tried to use it without material, but couldn’t solve it… then found some advices and tried with a noise texture and material…

if you check this picture: https://dl.dropbox.com/u/1276843/transparency.jpg

you can see the diffuse map in the material is perfectly shows the alpha, but on the gridshape no alpha is used….

any help would be much appreciated :)

Kevin

#66168
Jan 26, 2013 at 5:54am

i can not see your image, since my vpn seems to be blocked again in China, but sounds you want something like that:

– Pasted Max Patch, click to expand. –

[attachment=213329,4949]

Attachments:
  1. zwei.png
#238168
Jan 26, 2013 at 12:31pm

thanx Tobias, it seems the gridshape’s “@layer 2″ is the key for me, if i leave that on 0 then not working properly, but with any higher value it’s perfect… could you help me what’s this about? the text in the reference isn’t too helpful :D

“Object layer number (default = 0) When in automatic mode, the layer number determines he rendering order (low to high). Objects in the same layer have no guarantee which will be rendered first.”

anyways thanx for ur patch, works great :)

Kevin

#238169
Jan 26, 2013 at 12:43pm

the layer is about the order in which gl.objects are rendered (first layer 0, then layer 1 and so on…), but just think about it similiar to the layers in photoshop: standart layer is 0 (you can think of it as your “background layer”), higher numbers are on top (aka in front) of lower numbers…

also note that depth_buffering is disabled and blend_mode enabled for this to work in that way….

#238170
Jan 28, 2013 at 9:42pm

Yeah, thanx! I understand how layers are rendered, just not clear how this affects te alpha channel render. In the attached patch if i use layer higher than 0 for the plane, then it works perfectly… and sometimes if i use 0 as the plane layer it works well, but i guess because randomly it’s rendered in the right order… but i don’t get why the alpha channel is rendered well, if the layer is higher than 0and not, if it’s 0.

also need the depth buffer enabled, as it doesnt work if it’s disabled… then it covers other objects, what it shouldnt… but luckyly it works with depth buffer enabled :)

Also attached a PNG what’s used by the path…

thanx for your help again and in advance!

Attachments:
  1. CD3.png
#238171

You must be logged in to reply to this topic.