thispoly~muting/mute~/begin~ takes 40 ms

Feb 8, 2011 at 3:22am

thispoly~muting/mute~/begin~ takes 40 ms

Hi,
i’m trying to build a poly~-based player with many voices. Voice allocation switches on DSP processing in the subpatch that does the work. I need signals to be sent into the poly subpatch by use of send~/receive~ pairs.

Now i realized that switching on DSP using thispoly~ inside the poly~ takes a while until receive~d signals become available. It actually takes up to 40 ms – which is quite something!
Please find test patches attached demonstrating this behavior.
I tried with Max 5.1.7, Minimac CoreDuo, OSX 10.6.6

I hope it’s a bug to be fixed and not accepted behavior. It makes many poly~-based applications with tight message/signal timing impossible. Or is there any available workaround?

thanks and all the best,
Thomas

There are two patchers attached, the second must be named “test_mute_psub” so that it gets loaded into the poly~ of the first patch.

– Pasted Max Patch, click to expand. –
– Pasted Max Patch, click to expand. –
#54851
Feb 8, 2011 at 4:01am

audio preferences -> vectorsize 32

#197532
Feb 8, 2011 at 9:22am

You seem to be using send~ and receive~ from the poly~ to the rest of the patcher, this is not supported. It adds some unknown latency.

#197533
Feb 8, 2011 at 5:22pm

alright, thanks Emmanuel – i seem to have missed that it’s not supported…. gr~~~

#197534

You must be logged in to reply to this topic.