Forums > Max For Live

thresh not working in m4l ?

November 2, 2013 | 4:05 pm

Is this a known bug ?
l 9.0.6
max 6.1.4


November 4, 2013 | 12:56 am

can someone confirm this ?



mvf
November 4, 2013 | 2:55 am

Hi Chapelier,
works fine here. I simply put a "thresh 100" object after notein and stripnote and it gave me all the keys on the midikeyboard I pressed as a list.
I’m using Live 9.0.6 (32 Bit) together with Max 6.1.4 like you on OSX 10.8.5
Are you on Windows?
Martin


November 4, 2013 | 4:12 am

that’s so weird…
this works on max but not in m4l.
mac os 10.6.8

<code>

– Pasted Max Patch, click to expand. –

</code>


November 4, 2013 | 4:13 am

Ah !
in fact it works….but not in edit mode !
that’s still very annoying.


November 4, 2013 | 8:29 am

does it work without the print?


November 4, 2013 | 9:47 am

Ooops ! Yes it does ! it’s just not printed…
sorry for this…


November 4, 2013 | 12:31 pm

it still seems wrong that printing the list doesnt work.

maybe there is an intruder object called "print" in your search path.


November 4, 2013 | 1:10 pm

well…i don’t think so since i use it all the time to monitor stuff. i use it so much that i didn’t think to put a message box !


November 4, 2013 | 2:08 pm

For me thresh works in edit mode if Preview mode is on but NOT if Preview mode is off.

Can somebody confirm this behavior?


November 4, 2013 | 5:23 pm

-> support


November 6, 2013 | 9:31 am

We can confirm there something weird going on here and we’ll have a look at it

Sorry for the inconvenience

Cheers

-A


November 6, 2013 | 10:43 am

No worries !


July 9, 2014 | 12:15 am

I’ve just run into this bug ( 6.1.7 ). Are there any updates on the issue?


July 9, 2014 | 12:32 am

not that i know of.
i insist on the fact that tresh works perfectly, it just a problem with print / monitoring the value.


July 10, 2014 | 10:30 pm

Thanks for the reply Chapelier. When I’m editing the M4L device no data passes through the [thresh] object at all. I have [bang]s on all the object outputs of my chain and it stops dead at [thresh].

It works fine outside of edit mode.

*edit – it seems to occur with the [speedlim] object as well


Viewing 16 posts - 1 through 16 (of 16 total)