To open “MaxMSP,” you need a Java SE 6 runtime.

Nov 12, 2012 at 7:15pm

To open “MaxMSP,” you need a Java SE 6 runtime.

I emailed support with this. Their solution was to reinstall MAXMSP and that did not work.

- Lion comes with Java SE6, I updated the JRE and JDK to 7, deleted Java 6.

- java -version reports:
java version “1.7.0_09″
Java(TM) SE Runtime Environment (build 1.7.0_09-b05)
Java HotSpot(TM) 64-Bit Server VM (build 23.5-b02, mixed mode)

- java development in eclipse and xcode compiles and runs fine with 1.7

- I have this in my config file: max.java.jvm.version 1.7.0_09

- When I did have Java 6 installed last week, Max would open fine but refused to run my Java 7 projects (that’s why I deleted Java 6, to force max to run java 7)

- I don’t get it :(

#65187
Nov 12, 2012 at 11:31pm

Follow up from support: Max 5 will not work with Java 7. I reverted to Java 6 and everything is fine now. Anyone successfully using Max 6 and Java 7 SE?

#234930
Nov 13, 2012 at 8:38pm

Java 7 for OS X is 64-bit only; Max is currently 32-bit.

#234931

You must be logged in to reply to this topic.