Forums > MaxMSP

TouchOSC – sending blank messages

May 8, 2011 | 5:18 pm

Here’s the short: I am sending messages to labels in TouchOSC. This is easy, ie: /page1/label/ name But I also want to send messages to clear the labels. I can do this by typing in a message object:

;
ToiPad /page1/label/ "";

And when I click off the message object the "" go away and there is a space after the osc command and the semicolon. It works totally fine. But when I close the patch and reopen the semicolon is up against the osc command making the message useless.

help?
GW


November 19, 2011 | 10:54 pm

Have you tried doing some sort of a loadbang to reset the messages how you want when you reopen the patch?


November 19, 2011 | 10:59 pm

What actually worked was sending a message with a space: " ". Basically I was trying to build a typing interface so the user could label fader names how they wanted. I needed to be able to clear the name, or atleast have the appearance of a cleared label.


November 20, 2011 | 12:07 am

Hi,

there’s an external in my library called [sadam.empty], which would send you an empty ("") symbol each time you bang it (it will also detect messages with empty symbols). I built it exactly to handle the trouble with empty messages in Max. See http://www.sadam.hu/en/software for details.

HTH,
Ádám


November 16, 2013 | 1:19 pm

Sadam, i love externals like yours, which seem to deliver solutions to the most simple problems. However, i don NOT understand why C74 doesn’t take care of this simple thing (EMPTY message) themselbves. It seems like coders are unable to understand real life, really. And who knows, maybe there is a copyright problem involved. Just evil guessing hehehehe.


Viewing 5 posts - 1 through 5 (of 5 total)