Tremelo trouble with audio

Nov 29, 2010 at 11:16am

Tremelo trouble with audio

Hey guys!,

I’m making a patch to play my guitar through and everything seems to be working (kind of) so far. I’m trying to implement a tremelo object though and having no success.

Heres what I’ve got so far -

Audio Signal in – Splits to two mini patches (one clean and one OD) – SWITCH (to choose channel – Stereo Delay – Reverb – CompressorGateLimiter – Master Fader

I want to put the tremelo in just after the switch. I’ve tried creating a cycle~ object and a number~ but when I hook them up I can’t here anything. My master metres display signal going out but nothing can be herd.

If anybody could enlighten me on how I might be able to get it working I would be extremely grateful!. I’m abit of a noob so go easy ! :)

Many thanks,

Caatalyst

#53611
Nov 29, 2010 at 11:30am

post your patch: in Edit mode select all and go Copy Compressed, then paste it here. What version of Max are you on?

#192773
Nov 29, 2010 at 11:33am
– Pasted Max Patch, click to expand. –
#192774
Nov 29, 2010 at 11:45am

Hi,

Are you using the MSP object [number~] where perhaps you should be using the Max object [number]? Here’s an example:

– Pasted Max Patch, click to expand. –

-Eric

#192775
Nov 29, 2010 at 11:52am

how do I open that ?

#192776
Nov 29, 2010 at 12:16pm

I keep trying to copy and paste that information into different windows but it doesnt open anything :(

#192777
Nov 29, 2010 at 12:48pm

stupid me, I’ve opened it but unfortunately had no sucess getting it to work with my patch :(

#192778
Nov 29, 2010 at 2:02pm

you hooked up a cycle object but you dont hear anything? thats bad.

#192779
Nov 29, 2010 at 7:59pm

Did you run you audio into the first inlet of the [*~] object and out the outlet? If so, and it’s still not working, I would have no idea what the problem is. What I posted is the same way it’s done in the MSP tutorial 8: Tremelo and Ring Modulation. Perhaps you could take a look at that (if you haven’t already) and make sure it works in the tutorial patch on your computer, and if so you could copy it from there?

best,
Eric

#192780
Nov 29, 2010 at 8:23pm

signal to be “tremoloed” goes in one inlet of the *~, a cycle~ with your tremolo frequency goes in the other. you might need to scale the cycle~ input to a better level, run it through a gainfader~ before hitting the *~. very straightforward to implement this.

#192781
Nov 30, 2010 at 4:10am

You might find MSP Tutorials 8 and 9 to be helpful, especially 9.

#192782

You must be logged in to reply to this topic.