Trouble with an older compiled app, no audio output

Jul 17, 2008 at 6:59pm

Trouble with an older compiled app, no audio output

I’m having trouble with an older compiled app. Here are some of the errors it’s spitting at me. I can edit this app on a friends computer with max/msp, but I’m trying to find out why I’m not getting audio so that I know what to fix when I get there.

I’m assuming its an issue with otudp and OpenSoundControl being something different in the new version. Can anybody tell me if this in fact the source of my woes? The app seems to be behaving normally except for the lack of audio output. I can deal with some of the objects that are missing, but I’d like to first and foremost get the audio routing correctly.

• error: otudp: No such object
• error: OpenSoundControl: No such object
• error: otudp: No such object
• error: OpenSoundControl: No such object
coll: finished, 14 lines

• error: collect: No such object
• error: random-norep: No such object
• error: sequence: No such object
coll: finished, 232 lines

old CFM externals disabled
• error: umenu: doesn’t understand “freq”
• error: umenu: doesn’t understand “gain”
• error: umenu: doesn’t understand “Q”
• error: umenu: doesn’t understand “autoout”
• error: umenu: doesn’t understand “scale”
• error: umenu: doesn’t understand “spectrum”
• error: umenu: doesn’t understand “fullspect”
• error: umenu: doesn’t understand “range”
• error: umenu: doesn’t understand “done”
• error: Macintosh HD:/…/sahx~: loading old CFM
externals disabled
• error: Macintosh HD:/…/sahx~: loading old CFM
externals disabled
• error: Macintosh HD:/…//filtergraph~: loading
old CFM externals disabled
• error: umenu: doesn’t understand “freq”
• error: umenu: doesn’t understand “gain”
• error: umenu: doesn’t understand “Q”
• error: umenu: doesn’t understand “autoout”
• error: umenu: doesn’t understand “scale”
• error: umenu: doesn’t understand “spectrum”
• error: umenu: doesn’t understand “fullspect”
• error: umenu: doesn’t understand “range”
• error: umenu: doesn’t understand “done”

………

• error: otudp: No such object
• error: otudp: No such object
• error: otudp: No such object
• error: otudp: No such object
• error: otudp: No such object
• error: otudp: No such object
• error: otudp: No such object
• error: otudp: No such object
• error: OpenSoundControl: No such object
• error: OpenSoundControl: No such object
• error: otudp: No such object
• error: otudp: No such object
• error: OpenSoundControl: No such object
• error: otudp: No such object
• error: OpenSoundControl: No such object
• error: otudp: No such object
vst~: can’t find plug-in, using default
The 1 parameter of Default is:
P1
• error: vst~: can’t fragload fuzz, err -4
• error: cos-slider: No such object
• error: cresc-decresc: No such object
• error: Macintosh HD:/…/filtergraph~: loading
old CFM externals disabled
• error: #X: no such object
• error: #X: no such object
• error: #X: no such object
• error: #X: no such object
• error: #X: no such object
• error: #X: no such object
• error: #X: no such object
• error: #X: no such object
• error: #X: no such object
• error: #X: no such object
• error: #X: no such object

#38924
Jul 18, 2008 at 12:58am

This app was compiled under os9 but works for a friend of mine after installing max for osx. For some reason even under the same version runtime it appears not to be outputting audio.

I’m wondering if I can point the application to an updated object rather then openSoundControl and otudp.

Any help is greatly appreciated.

#136256
Jan 23, 2009 at 9:39pm

any luck with the app ? I assume you were looking at !dschihad…

#136257

You must be logged in to reply to this topic.