Trouble with Fullscreen in Presentation mode

Apr 15, 2011 at 2:04pm

Trouble with Fullscreen in Presentation mode

Hi all.

I am trying to figure out a little problem i am having with fullscreen.

This is my patch to put it in context: (you will need to unlock it and switch to patcher mode to view it)

– Pasted Max Patch, click to expand. –

Basically what I want is when the patch opens loadbang tells it to go in to fullscreen in PRESENTATION mode. I don’t want the users to see the patch working away underneath but just to see what i am laying out in presentation. for some reason I can only make it either go to fullscreen in patcher mode, or switch to presentation mode on opening but without it being fullscreen.

I tried to attach the two messages for fullscreen $1 and presentation $1 together but that lead to ‘fullscreen: bad number” in my Max window. I think i’m probably being a bit special so any help much appreciated.

Also, you will see that my ~adc is also controlled by loadbang. Is there a way that I can have the ~gain up and the sound input working as soon as the patch is opened? Because at the minute I am having to manually set the level each time I open it which defeats the purpose of my loadbang. Have had a scoure through the forums but can’t see anything similar.

Thanks in advance,

Kelz x

#56347
Apr 16, 2011 at 11:45am

Hi,

If you want your patch to open in presentation mode, the best way is to use
the patcher inspector (menu view->patcher inspector, or cmd+shift+i)
and to check the “open in presentation” checkbox (in the view tab).

#202130
Apr 17, 2011 at 2:03am

To have your patch start with MSP “on”, put a [delay 1000] after the [loadbang]. It seems that Max needs to wake up fully before MSP can be started. Without the delay, the loadbang is lost. By delaying the loadbang, you’re giving Max the time to grab a cup of coffee before it has to wake MSP up.

#202131
Apr 17, 2011 at 11:32am

Thanks guys that’s really useful.

One question though. Will using the ‘open in presentation’ check box allow it to go full screen as I don’t want anything else visible? Or will i need to pop in another command somewhere? That is the issue I can’t really seem to figure out. I can get fullscreen in patcher but not presentation?

#202132
Apr 17, 2011 at 8:26pm

Opening in Presentation still lets you go into fullscreen in exactly the same way as it does in patching mode, give it a try. I’m not able to knock up an example patch right now but if I will at some point if you need a demonstration.

#202133
Apr 19, 2011 at 9:27am

That would be gred dickmedd. I can’t see where to add the fullscreen to make it work with the presentation mode. I tried adding [thispatcher] and then [fullscreen] but it doesn’t do anything to the presentation mode which it now opens in.

#202134

You must be logged in to reply to this topic.