Forums > Jitter

trouble with new jit.gl.model and/or openCollada

January 30, 2012 | 1:22 pm

hello all

I am Trying to start using the new feauters of jit.gl.model,
what i want to do is this:

1.set up a skinned model in 3dsmax 2012, with bones

2.export to max (i am using OpenCollada) //this might be where the problem is

3.use jit.model to animate the model ver the bones, set up in 3dsmax

here is a test file from 3dsmax exported using opencollada, which is not working
the image is a screen shot of the model in 3dsmax

although this my not be a max problem, perhaps you can help
so my question is,
what is the best exporter to export 3d skinned model?
if that is opencollada what is best practice for exporting, is there any tutorials,

if rob reads this how did he make his Seymour.dae?
i can use blender a bit too but i known 3dsmax the best, but if it works in
another 3d software package I will jump ship.

any help would be amazing, i love to get this workflow working!!

best
Ben

.

Attachments:
  1. file.JPG

January 30, 2012 | 10:33 pm

Why you don’t try .obj instead ? For me it works well.


January 31, 2012 | 11:28 am

I gave obj a try, but could not get the skin to work at all, what export setting are you using?

but I did get openCollada to work, the secret is to map all the vertices to bones, then you can use it in max!!


January 31, 2012 | 5:04 pm

hi strimbob.
glad you got it working.

unfortunately, there is no easy answer for this stuff, as it always depends on the specific modeler and exporter you are using.

generally, i can say a few things. as you mentioned, all vertices should be bound to the skeleton, and conversely, all bones should be bound to at least one vertex.
all transformations on the mesh should be zero’d (frozen, reset, whatever the nomenclature) before binding it to the skeleton. all history should be deleted on the mesh before binding to the skeleton.
if at all possible, all the local axes of the bones of the skeleton should line up with the world axes, and for the bind pose, their rotations should be 0.

obj objects, as you discovered, do not support skinning.

we hope to have some tutorials documenting a bit of the pipeline for this stuff in the near future.


January 31, 2012 | 9:13 pm

Thanks for all the info, very much appreciated


Viewing 5 posts - 1 through 5 (of 5 total)