Forums > MaxMSP

Trouble with Xsample Library

June 20, 2008 | 7:26 pm

Does anyone here use the xsample library?

http://www.parasitaere-kapazitaeten.net/~thomas/ext/

I have downloaded it, but it doesn’t come with any patches. How do I gain access to its 3 objects? Is anyone able to just post the xgroove~, xrecord~, and xplay~ objects if they have them?


June 20, 2008 | 7:49 pm

I haven’t tried them in Max 5 yet, but they’re working just fine in 4.6.
Afaicr, there’s just there is no actual xgroove~ etc. just xsample~ object
itself, which is mapped to xgroove~ etc. via an init text file, so how you
install it is crucial.
>From the read Me:
‘ For Mac OSX it is best to put the max-osx/xsample.mxd file into the folder
/Library/Application Support/Cycling ’74/externals
and the file maxmsp/xsample-objectmappings.txt into the folder
/Library/Application Support/Cycling ’74/init .’

This obviously refers to pre-5 Max, but I imagine that just translates to
Cycling74/Externals and ~/Cycling74/Init.
Great set of objects – I hope they do work in M5,
cheers
Roger

On 20/06/2008 20:26, "Kyle Kaplan" wrote:

>
> Does anyone here use the xsample library?
>
> http://www.parasitaere-kapazitaeten.net/~thomas/ext/
>
> I have downloaded it, but it doesn’t come with any patches. How do I gain
> access to its 3 objects? Is anyone able to just post the xgroove~, xrecord~,
> and xplay~ objects if they have them?
> –
> -k.


June 21, 2008 | 4:05 pm

i followed the read me and got the following error when trying to use an x object:

"xsample.mxd: unknown external object"

i tried it in 4.6 and got the following error:

"loading old CFM externals disabled"

any suggestions?


June 21, 2008 | 5:10 pm

the object posted on thomas’ site is the old non-ub version. you need the new beta version. And, not to be a dick, but if you do search for xsample in th Max forum you will find this link: http://grrrr.org/ext/beta/

(searching is your friend)

Now thats just the object compiled for leopard and 4.6. It works fine there i haven’t tried it since i updated to max 5, but based on my experience with other non-ui 3rd party objects in max 5, it should work just fine.

you will still need to download and install the help files and whatever else comes with the xsample object from the link you posted. you can follow the same instructions (adapted to max 5) but use the xsample.mxo from the beta site instead of the .mxd.

cheers
j5


Viewing 4 posts - 1 through 4 (of 4 total)