Forums > MaxMSP

Trying to build my first max external with xcode

October 19, 2011 | 5:28 pm

So I downloaded the SDK and just opened simplemax.xcodeproj in xcode 4.2 and tried to build it.

I’m getting the message

"The run destination My Mac 64-bit is not valid for Running the scheme ‘max-external’"

Anyone managed to get any of these examples built with xcode 4.2?


October 19, 2011 | 7:50 pm

OK — we figured this out — it’s necessary to comment out the following three lines in the maxmspsdk.xcconfig file. Once one does that, objects build just fine.

//SDKROOT = /Developer/SDKs/MacOSX10.4u.sdk

//GCC_VERSION = 4.0

//MACOSX_DEPLOYMENT_TARGET = 10.4


February 16, 2012 | 2:51 am

Good call. Thanks!


Viewing 3 posts - 1 through 3 (of 3 total)