turn off modifier click

Dec 6, 2013 at 3:08pm

turn off modifier click

Hi all,

I have a third party max plug In which reacts on SHIFT + ALT + click, but is overridden from Max´s “open help” – command.

How could I switch off the max assignment so that I can work with my plug in´s assignments?

Thx
Best
TM

#275002
Dec 7, 2013 at 12:56pm

Not sure if it will help with your specific issue but I have had success editing the interfaces/maxinterface.json file in the Cycling ’74 folder to change hotkeys and menu commands.

#275054
Dec 7, 2013 at 7:29pm

Metamax,

thank you for your help!!!!
I went through the whole list you mentioned
lots of short cuts, but no such thing as

shift+alt+click

or

shift+option+click.

Must be hidden somewhere else…
Thank you very much!!!!

Best
Tim

#275069
Dec 7, 2013 at 8:03pm

That’s probably because the open help command is option/alt+click. No shift.

#275075
Dec 8, 2013 at 4:37am

okay,

but how to deactivate those modifier click commands—?

Thx
T

#275096
Dec 8, 2013 at 5:17am

Well, considering there is no “shift+alt+click” command standard in Max, you might consider other sources for the conflict. What OS? Third party apps running in the background? Which external are you using?

At the very least did you remove the alt+click entry in the config file to see if it resolved the problem? Not to mention that it’s an external built for Max.. perhaps contacting the creator might help.

All pretty standard in terms of troubleshooting…

#275100
Dec 8, 2013 at 5:31am

Thanks,

I chose turning the help off. I am afraid to ask in standard terms for the real pros, but where is this config file?

Thank you very much!!!

Best
T

#275101
Dec 8, 2013 at 8:10am

Where MetaMax said it is. In the Max folder: Cycling ’74/interfaces/maxinterfaces.json

Thing is, I think the “option-click on object to open its .maxhelp file” thing is hard-wired. (At least, I’ve never seen where it can be configured, either in the interfaces/ folder or in the init/ folder. And those are the two obvious places.)

On some versions of Max, option-click may be “greedy” (i.e., match if any additional mod keys are held at the same time, for isntance, your shift-opt-click on Mac, or shift-alt-click on Windows.)

It would still be a lot more helpful if you’d tell us what version of Max you’re running and on what platform. We’re not bloody mindreaders, and everything else is stabbing in the dark.

#275119

You must be logged in to reply to this topic.