two jit.qt.grab won't work at once

Oct 24, 2012 at 7:20pm

two jit.qt.grab won't work at once

Hey,

I try two use two jit.qt.grab in one patch without success. The input comes from a Blackmagic Decklink Duo. (Two seperated SDI inputs).
I can only open one with one jit.qt.grab. The other one is not doing nothing.

I opened Max in a second instance (copying the programm and open it a second time). There I can have the second camera opend. But I need them in one render-context.

Any help?

Thanx, luke

#64915
Oct 24, 2012 at 9:33pm

for an opera play i made a patch with 8 jit.qt.grab objects
using firewire cams .

had lots of problems with data rate . had to add extra firewire busses.

can you post a patch ?

#234045
Oct 25, 2012 at 9:24pm

thanks for the answer.
I don’t have the patch with me now (and it looks like a mess, with all the other stuff going on ;) ), but basically it is just putting to jit.qt.grab in one patcher and trying to open two sources. It just won’t do it. I can only select one or the other source. The second grab object doesn’t react, as soon as the other one is open… I tried putting the grab object in a Bpatcher, but that didn’t help eather.

I helped myself by making a copy of my Max-Application and launched Max a second time. In the “second” Max I could then use another jit.qt.grab to open the second source. Using jit.net.send and jit.net.recv gets the video to the first Max-Application where I can simply embed it into the rest…
Mayby not the prettiest solution, but it works for now, which is important, because tomorrow is opening night ;)

Anyway, if there is another way to solve it without opening Max twice, I am happy to know it! :)

Good night, luke

#234046
Oct 26, 2012 at 4:13pm

Hello,
if you have two cameras connected you can use the @input (0,1, ecc) attribute to select the video inputs. I’m not sure if it will run with your card.
See the patcher enclosed.
Ciao,
ric

– Pasted Max Patch, click to expand. –
#234047

You must be logged in to reply to this topic.