Forums > Jitter

Two New Recipes!!

August 30, 2007 | 12:10 am

I hope you’ve got a big appetite….

These sleepy summer days have afforded me some time to get back into the
kitchen and whip up some more tasty treats for you guys.

http://www.cycling74.com/story/2006/2/17/153427/406

Recipe 39: Preview — Pretty much what the name implies. Uses texture
readback and shared_context to provide a nice OpenGL preview window.

Recipe 40: SceneWarp — Uses texture feedback and distortion to make
some gloopy swirly effects. This recipe shows a nice advanced technique
for texture feedback, and for managing render order with jit.gl.sketch
objects and "layer" attributes.

Don’t forget your veggies…

Happy Patching!
Andrew Benson


August 31, 2007 | 12:39 pm

Resipe 40, SceneWarp look great the first time when I tried it on a mac. On
a windows pc I changed the jit.qt.grab to jit.dx.grab for a working result,
jit.qt.grab gives me my windows some distorted vertical lines. But is there
something with the lumagate shader differ on mac and windows? On the mac the
luma works fine but my windows machine gives no luma-key-like-effect that
was meant. The luma range works for filtering light/dark but no luma key.

hmm, I must get a bit more into these shaders… or is it something else.

I used the uyvy colormode in the jit.dx.grab btw.

cheers,
ra.

2007/8/30, andrew benson :
>
> I hope you’ve got a big appetite….
>
> These sleepy summer days have afforded me some time to get back into the
> kitchen and whip up some more tasty treats for you guys.
>
> http://www.cycling74.com/story/2006/2/17/153427/406
>
> Recipe 39: Preview — Pretty much what the name implies. Uses texture
> readback and shared_context to provide a nice OpenGL preview window.
>
> Recipe 40: SceneWarp — Uses texture feedback and distortion to make
> some gloopy swirly effects. This recipe shows a nice advanced technique
> for texture feedback, and for managing render order with jit.gl.sketch
> objects and "layer" attributes.
>
> Don’t forget your veggies…
>
> Happy Patching!
> Andrew Benson
>


August 31, 2007 | 2:59 pm

Hi Ranja,
Are you seeing any error messages in the Max window?

What type of graphics card are you using on your Windows box? Do other
C74 shaders work on this machine?

When you say that the "range works for filtering light and dark", what
exactly do you mean? Have you set a fade amount? Please tell me what
you are seeing exactly so that I can better tell what is creating
trouble for you.

Best,
Andrew B.


September 18, 2007 | 3:03 pm

Hi Andrew,
I saw my reply didn’t make it to the forum while I send more than one
attachments. So once again.

I’m running in Vista 64 bit on a intel core 2 duo, nvidia GeForce 7900 GTX
graphic card, max 4.6.3 / jitter 1.6.3.

There are no errors in the max window and other c74 shaders are working on
this machine. The lumagate shader is working when I change the luma range
and fade variables. I can change the threshold of light and dark. Only on
the pc there is no feedback like there is on the mac.

Some examples can be found here

http://www.ranjaachbar.com/crp/jitter_recipes.html

In the first place I turned off /bypassed the mesh distortion to see what
happens [see here]< http://www.ranjaachbar.com/crp/jitter_recipes.html#scenewarp_pc_1>and
when I turned on the mesh distortion you get this
<
http://www.ranjaachbar.com/crp/jitter_recipes.html#scenewarp_pc_2>result.
Maybe that is the intention because it looks like the example image on the
c74 jitter recipes site<
http://www.cycling74.com/story/2006/2/17/153427/406>.
But when using on the mac (G5, PowerPc), the thresholded luma part is
feedbacked [see
picture<
http://www.ranjaachbar.com/crp/jitter_recipes.html#scenewarp_mac>]
(dark area is feedbacked and warped).

When you say that the "range works for filtering light and dark", what
> exactly do you mean?
>
By "range.." i meant the threshold of the lumagate/lumakey or the lum param.

thanks,
ra.

2007/8/31, Andrew Benson < andrewb@cycling74.com>:
> >
> > Hi Ranja,
> > Are you seeing any error messages in the Max window?
> >
> > What type of graphics card are you using on your Windows box? Do other
> > C74 shaders work on this machine?
> >
> > When you say that the "range works for filtering light and dark", what
> > exactly do you mean? Have you set a fade amount? Please tell me what
> > you are seeing exactly so that I can better tell what is creating
> > trouble for you.
> >
> > Best,
> > Andrew B.
> >
>
>
>


September 19, 2007 | 12:47 am

Hi Andrew,

I am a Jitter beginner/ I have been playing around with, your Video Synth patch and was wondering if it was possible to attach that patch to a live video feed?

I need help!

Thanks!


September 19, 2007 | 1:16 am

Well, yes it is possible, of course.

The thing you will need to ask yourself is in what way you want to use
the live video feed. Are you compositing the video-synthesis drawing
stuff with a live feed, or are you trying to distort the live feed the
way that the drawing is getting distorted? I would recommend looking at
the jitter tutorials and the other recipes for ideas about how this
might be worked out.

Everything between jit.qt.grab and jit.window is your choice to be made…

Happy Patching!

Andrew B.

myspacegrab wrote:
> Hi Andrew,
>
> I am a Jitter beginner/ I have been playing around with, your Video Synth patch and was wondering if it was possible to attach that patch to a live video feed?
>
> I need help!
>
> Thanks!
>


September 19, 2007 | 1:33 am

Hi Andrew,

Thanks for the response. I am trying to distort the live feed the
way that the drawing is getting distorted. I guess the question I asking is there anyway I could just connect a live video feed patch to your exsisting patch? Or not so simple?


September 19, 2007 | 1:43 am

replace jit.qt.movie, or whatever is the source of the texture with
jit.qt.grab.
On Sep 18, 2007, at 9:33 PM, myspacegrab wrote:

>
> Hi Andrew,
>
> Thanks for the response. I am trying to distort the live feed the
> way that the drawing is getting distorted. I guess the question I
> asking is there anyway I could just connect a live video feed patch
> to your exsisting patch? Or not so simple?

v a d e //

http://www.vade.info
abstrakt.vade.info


September 19, 2007 | 2:00 am

Thanks Vade,

I had a look for any jit.qt objects but couldnt find any, heres a screenshot of the patch.

http://img227.imageshack.us/img227/4990/maxmspscreensnapz002tw9.jpg

Any other ideas?


September 19, 2007 | 2:12 am

look inside the [p video] sub patch.

and go through the max/jitter tutorials.

On 9/18/07, myspacegrab wrote:
>
> Thanks Vade,
>
> I had a look for any jit.qt objects but couldnt find any, heres a screenshot of the patch.
>
> http://img227.imageshack.us/img227/4990/maxmspscreensnapz002tw9.jpg
>
> Any other ideas?
>


September 19, 2007 | 2:13 am

p video subpatch?
On Sep 18, 2007, at 10:00 PM, myspacegrab wrote:

>
> Thanks Vade,
>
> I had a look for any jit.qt objects but couldnt find any, heres a
> screenshot of the patch.
>
> http://img227.imageshack.us/img227/4990/maxmspscreensnapz002tw9.jpg
>
> Any other ideas?

v a d e //

http://www.vade.info
abstrakt.vade.info


September 19, 2007 | 9:03 pm

I tried mucking around with the "p video" subpatch and tried adding my video feed patch, but nothing seemed to work, I added a screenshot below. Ah Crazy!

http://img233.imageshack.us/img233/5413/maxmspscreensnapz001vd4.jpg


Viewing 12 posts - 1 through 12 (of 12 total)