Forums > MaxMSP

UB vs OSX ??

April 8, 2007 | 12:29 pm

hi

sorry – it really seems there is something i did not get in this UB thing….

Always thought UB stands for "universal binary" and that thise meant
you could use it on PPC macs AND Intel macs (running osX48 in my case)

but it seems all UB maxmsp objects (that’s those with .mxo , right??)
do not show in my max patches, or rather show but without
inlets/outlets… or at least it just happend with a few objects from
different sources (all 3rd party so far… CNMAT, Olaf Matthes…)

so does it mean than UB is universal only on intel macs (???) or that
my max is not UB-ready (yes I still use the very old 457 version) ??

thanks

kasper

Kasper T. Toeplitz
noise, composition, bass, computer

http://www.sleazeArt.com

http://www.myspace.com/sleazeart


April 8, 2007 | 12:44 pm

Kasper T Toeplitz wrote:
> hi
>
> sorry – it really seems there is something i did not get in this UB
> thing….
>
> Always thought UB stands for "universal binary" and that thise meant you
> could use it on PPC macs AND Intel macs (running osX48 in my case)
>
> but it seems all UB maxmsp objects (that’s those with .mxo , right??) do
> not show in my max patches, or rather show but without inlets/outlets…
> or at least it just happend with a few objects from different sources
> (all 3rd party so far… CNMAT, Olaf Matthes…)

.mxo does not really mean UB. In max 4.5 .mxo were introduced so there
are pre-UB .mxo externals around. Another thing (at least with my
externals) is .mxo externals for Max 4.6 that link to other libraries.
Sometimes these libraries are not (yet) available as UB so, there is one
PPC and one Intel Mac external (both .mxo, of course) for Max 4.6 and
another .mxo for Max 4.5. Pretty confusing, right?

Olaf


April 8, 2007 | 12:55 pm

> Pretty confusing, right?
>
>

you bet

that’s why your gigaverb~.mxo does not have in/outlets on my PPC max457???

(by the way I posted a few days ago a mail about gigaverb~ – ppc
version – crashing max later or sooner IF i change its second
agrument (in the range 1-100, I tried with 45..). This was confirmed
by a friend, on his own PPC… I never saw this mail on the list….)

best

kasper

Kasper T. Toeplitz
noise, composition, bass, computer

http://www.sleazeArt.com

http://www.myspace.com/sleazeart


April 8, 2007 | 1:19 pm

Kasper T Toeplitz wrote:
>> Pretty confusing, right?
>>
>>
>
>
> you bet
>
> that’s why your gigaverb~.mxo does not have in/outlets on my PPC max457???

Usually Max 4.5.mxo externals crash Max when you try to load them in Max
4.6.
You really have to check whether you downloaded the right version (Max
4.5 versus 4.6) and make sure not to have any other copies of it in the
Max search path. The bad thing is you can’t see from looking at the
files whether they are 4.5 or 4.6. So the best thing is to donwload the
externals again.

> (by the way I posted a few days ago a mail about gigaverb~ – ppc version
> – crashing max later or sooner IF i change its second agrument (in the
> range 1-100, I tried with 45..). This was confirmed by a friend, on his
> own PPC… I never saw this mail on the list….)

I just tested it here, changing the second creation argument did not
crash on a MacBook using Max 4.6 and the gigaverb~1.0test5 UB, don’t
have a PPC at hand right now to test it there.

Olaf


April 8, 2007 | 1:54 pm

>
>
>>(by the way I posted a few days ago a mail about gigaverb~ – ppc
>>version – crashing max later or sooner IF i change its second
>>agrument (in the range 1-100, I tried with 45..). This was
>>confirmed by a friend, on his own PPC… I never saw this mail on
>>the list….)
>
>I just tested it here, changing the second creation argument did not
>crash on a MacBook using Max 4.6 and the gigaverb~1.0test5 UB, don’t
>have a PPC at hand right now to test it there.

ppc, max457

I does not crash max immediately. usually in the 2-10 minutes – I
just tried it again, changed the 15 value To 25 (in the help patch)
put the dsp back on on the patch I am working on….multi-coloured
balloon…. max quits

took 1 minute or so

do you want the crash log???

could the spead be a message (not an argument)?

kasper


April 13, 2007 | 4:32 pm

Kasper T Toeplitz schrieb:
> so does it mean than UB is universal only on intel macs (???) or that my
> max is not UB-ready (yes I still use the very old 457 version) ??

The latter, UB requires 4.6.x But you can safely install 4.6 and still
keep your old 4.5.7 install as the places where stuff is stored has
changed as well, they should not interfere….

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


Viewing 6 posts - 1 through 6 (of 6 total)