Ubu-populatus Interruptus

Feb 8, 2006 at 11:42pm

Ubu-populatus Interruptus

I’m using tiered UBU-menus to load movies in Jitter. I have three menues; general category, subcategory, and then the files themselves. Each time I populate a menu, it freezes my video output as the files/folders are read into the directory. This is different then delays caused when files themselves actually load. Is there a way I can keep this from happening by defering or isolating the threading of that function. I suppose I expect a bit of a hit when the files themselves load, but I’m getting little pauses everytime I navigate through my menus.

#24336
Feb 9, 2006 at 6:35am

How many items are we talking about? There’s likely nothing that you
can do about this, although there might be stuff that we can do in
future releases.

jb

#70251
Feb 9, 2006 at 9:27am

Top Tier 35 folders… But this only populates once, so not a problem.
Middle tier from 2 to 25 folders per folder
Bottom tier 5-20 items per folder.

Though, I just tested with a single file running, and selecting a folder with a single file in it. Same as selecting a folder with a bunch of files.

The pause feels like.
Left click, choose item, unclick, HANG, resume playback. It seems as if the act of the query, as opposed to the act of filling the menu is when the pause comes.
A very subjective statement.

XP, latest versions of Max/MSP Jitter
v6.5 of Quicktime.

#70252
Feb 9, 2006 at 2:40pm

I have the same problem and concerns as Leo. It happens to me even when an ubumenu is reading less than a dozen movie files out of a directory.

Adam

#70253
Feb 9, 2006 at 6:02pm

Thanks, problem registered. Please don’t expect a fix immediately,
though.

jb

#70254
Feb 13, 2006 at 3:55am

Moving this thread to Jitter…

#70255

You must be logged in to reply to this topic.