Forums > MaxMSP

[udpreceive] is there a way to force max to use a certain network interface?


Jan
July 14, 2013 | 3:53 am

I am on a MacbookPro and currently working with OSC/udp data. The data comes in via the ethernet port. Unfortunately as soon as the Wifi connection is enabled it seems to take priority over ethernet and [udpreceive] does not receive the data anymore.
Is there a way to force max to listen to a certain network interface? I played around with the interface priorities in the OS X system settings, but no success so far….

Jan


July 14, 2013 | 12:42 pm

Hi,

without knowing more details, I would guess that the problem lies elsewhere. Objects like [udpreceive] don’t listen on a specific interface, but on a specific port. So here’s my question: are you sure that the messages actually do reach your computer at all?

Theoretically, it could happen that, when you enable the WiFi, the router assigns a new IP address to your network interfaces (including the ethernet card). Could you please confirm whether the IP address of your ethernet remains the same after turning the WiFi on?

Cheers,
Ádám



Jan
July 14, 2013 | 2:20 pm

Thanks for the hint, Ádám. Indeed it was another problem: I used DHCP with a manual address before and switching to a static IP solves the problem!!

Cheers,
Jan


March 28, 2014 | 4:08 pm

Hi there. I’m actually having the issue as originally described currently. I have a VPN network set up, and I’m not seeing the UDP messages show up over the VPN from via the tun0 (VPN pseudo-interface). I can, however, verify that the messages are coming in with a OSC dumper that I wrote in Node.js.

Ideally, I could specify the device that udpreceive is listening on, or force it to listen to all devices.

Any help would be appreciated!

dean.



Jan
March 29, 2014 | 5:35 am

Hi dean
as adam mentioned correctly in his reply to my original post udpreceived is not bound to an interface but to a port. One guess is that the issue might be port related. As far as i remember vpns are sending on one specific port only. Are you listening to the vpn port in max?
Jan


Viewing 5 posts - 1 through 5 (of 5 total)