Forums > MaxMSP

UI bug

March 18, 2010 | 12:01 pm

hi,

i found a strange behavior when locking/unlocking a patcher. if you lock/unlock very fast, a magic thing happens.

look at this : http://ev.gui.free.fr/UI-bug.mov

g


March 18, 2010 | 4:24 pm

Hmmmm, I cannot reproduce at all. Is this only with the newest version of Max? What’s your system?


March 18, 2010 | 4:29 pm

hi,

i’m on osx 10.6 up to date with max 5.1.3.

g


March 18, 2010 | 4:33 pm

you need a large patch with a lot of hidden-on-lock object.

try this one, i can reproduce it after few cmd+(double-clic) tries.

– Pasted Max Patch, click to expand. –

March 18, 2010 | 4:46 pm

Ah, I can do it too. But for me it seems that Max suddenly slows down enormously too, I’m unable to select objects after it does that strange thing. Closing down Max also becomes a lot more difficult, I tried to Quit a couple of times, but ended up using Force Quit as it didn’t do anything.

Max 5.1.3 (41767) on MacOS 10.5.8.


March 18, 2010 | 4:47 pm

yes max slows down more with this patch than with the one used in the video i uploaded… i don’t know why.


March 18, 2010 | 6:42 pm

I can’t reproduce any problems locking and unlocking this patch on either platform

-A


March 18, 2010 | 8:47 pm

I can reproduce this, on Mac OSX 10.6.2 and Max 5.1.3. I have to lock and unlock insanely fast, but it does happen.


March 18, 2010 | 11:20 pm

Can’t reproduce on Max 5.1.3, OSX 10.5.8.


March 19, 2010 | 9:27 am

you didn’t clicked fast enough ;)


September 20, 2010 | 12:19 pm

hi there,

this bug is still present in 5.1.5 version of max.

cheers,

g

[attachment=141940,1157]

Attachments:
  1. uibug-5.1.5.png

Viewing 11 posts - 1 through 11 (of 11 total)