Umenu behaves strangely

Jan 1, 2013 at 11:26pm

Umenu behaves strangely

Hi!

I'm using umenu to select audio files I added in a folder in the Max Msp app folder (like the examples/sounds/ folder that is used in a number of help patches. I have set the umenu on autopopulate mode. It worked fine until I reopen my patch : the umenu object has disappeared and there is just a striped box with (menu) written on it. Does anyone know why ?

Thanks!

[attachment=211492,4829]

Attachments:
  1. Capturedcran2013010123.52.31.png
#65877
Jan 1, 2013 at 11:43pm

I would just open up the inspector for the [umenu] object you’re using and set the folder with the audio you want there. Easier than using loadmess. Not sure why you’re getting the strange striped box, though…

#237237
Jan 2, 2013 at 12:06am

Thanks ! I tried it. The result is similar. I use 3 umenu objects because I have 3 categories of audiofiles, and 1 umenu would be really too long. Do you think it’s because I’m using several objects? I read that the stripes are due to juibogus objects but I have no clue of the reason why they appear. It’s appearently a programming error… I could perfectly insert the names of the audio files in the menu with an insert message, but I have quite a lot of files, and also, I would really like to be able to store those files in a specific folder, as my patches are quite numerous, it’s for a big project, and at least I’d like to be able to have the files apart…. Do you know if there is a means to indicate a path to a subfolder to sfplay~?
Regards
Coralie

#237238
Jan 2, 2013 at 12:15am

As far as I know, the umenu object does not support subfolders… but you can try something like this:

– Pasted Max Patch, click to expand. –
#237239
Jan 2, 2013 at 12:26am

Perfect! Thank you so much!!

#237240
Jan 2, 2013 at 8:00am

MMM Actually I still have the same problem using a subfolder…I have tried without using any subfolder, and it still didn’t work. I wonder if the depth argument doesn’t have anything to do with that problem. There is nothing clear about that in the help files or documentation. I have the feeling my patch is creating the problem, but I don’t know why. I’ll post it if it maybe of any use….

#237241
Jan 2, 2013 at 8:41am

Here is the file…. There is a number of abstractions in it that I won’t upload, but I guess it won’t change anything to the problem. If anyone has a clue…. I’m getting desperate. You must open it in normal mode, not in presentation mode to see the umenu objects.

Attachments:
  1. EqualAndPan.maxpat
#237242
Jan 2, 2013 at 9:15am

Hey there,

This is what it looks like when I open your patch up. Everything seems to be working fine and there is no striped box.

I have no clue what's going on. Hopefully somebody here with more knowledge than me can help you out.

Hope your problem will be resolved.

[attachment=211506,4831]

Attachments:
  1. ScreenShot00250102at1.05.42AM.png
#237243
Jan 2, 2013 at 3:47pm

HI,

Well, that’s really weird. I have used another solution meanwhile, with a preload message…. and it works fine. But thanks for your help anyway!

#237244

You must be logged in to reply to this topic.