Forums > MaxMSP

Unable to build a standalone with ftm object

March 24, 2010 | 11:31 am

Hi,

May be it’s not the rigth place to speak of that but I have difficulties to build a standalone with ftm objects.
I’ve tried :
- Build the standalone as usual. When building, in the Max Window I can read
‘Copying External gbr.slice~
Copying External gbr.wind=
Copying External gbr.fft
Copying External dac~
Copying External ftm.jitter
Copying External jit.matrix’
So I guess that ftm and gbr objects are correctly integrated. But not. When I run the sstandalone I’ve got the errors :

‘ftm.jitter: unable to load object bundle executable
2010-03-24 12:22:12.916 micro-matrix2[783:20b] Error loading /private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryItems/appRuntime-mxt/ftm.jitter.mxo/Contents/MacOS/ftm.jitter: dlopen(/private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryI
tems/appRuntime-mxt/ftm.jitter.mxo/Contents/MacOS/ftm.jitter, 262): Library not loaded: @loader_path/../Frameworks/FTMlib.framework/Versions/2.5/FTMlib
Referenced from: /private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryItems/appRuntime-mxt/ftm.jitter.mxo/Contents/MacOS/ftm.jitter
Reason: image not found
gbr.fft: unable to load object bundle executable
2010-03-24 12:22:12.978 micro-matrix2[783:20b] Error loading /private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryItems/appRuntime-mxt/gbr.fft.mxo/Contents/MacOS/gbr.fft: dlopen(/private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryItems/a
ppRuntime-mxt/gbr.fft.mxo/Contents/MacOS/gbr.fft, 262): Library not loaded: @loader_path/../Frameworks/FTMlib.framework/Versions/2.5/FTMlib
Referenced from: /private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryItems/appRuntime-mxt/gbr.fft.mxo/Contents/MacOS/gbr.fft
Reason: image not found
gbr.wind=: unable to load object bundle executable
2010-03-24 12:22:13.042 micro-matrix2[783:20b] Error loading /private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryItems/appRuntime-mxt/gbr.wind=.mxo/Contents/MacOS/gbr.wind=: dlopen(/private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryIte
ms/appRuntime-mxt/gbr.wind=.mxo/Contents/MacOS/gbr.wind=, 262): Library not loaded: @loader_path/../Frameworks/FTMlib.framework/Versions/2.5/FTMlib
Referenced from: /private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryItems/appRuntime-mxt/gbr.wind=.mxo/Contents/MacOS/gbr.wind=
Reason: image not found
gbr.slice~: unable to load object bundle executable
2010-03-24 12:22:13.081 micro-matrix2[783:20b] Error loading /private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryItems/appRuntime-mxt/gbr.slice~.mxo/Contents/MacOS/gbr.slice~: dlopen(/private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryI
tems/appRuntime-mxt/gbr.slice~.mxo/Contents/MacOS/gbr.slice~, 262): Library not loaded: @loader_path/../Frameworks/FTMlib.framework/Versions/2.5/FTMlib
Referenced from: /private/var/folders/Aw/AwNHbt1tFtyxJSNuhB9XQk+++TI/TemporaryItems/appRuntime-mxt/gbr.slice~.mxo/Contents/MacOS/gbr.slice~
Reason: image not found’

- When I tried to add the object in the script window of the build the errors are the same.

Any ideas of the rigth way to build standalone with ftm objects ?
Best


March 24, 2010 | 1:04 pm

You might need to move stuff by hand, but the best place to ask for FTM is at ircam: http://ftm.ircam.fr/
And regarding standalones its covered on its own FAQ page: http://bit.ly/9CnJt9

Stefan


March 25, 2010 | 2:11 pm

Thanks Stefan,

The Faq page is the rigth place for the instructions.

Any way i’ve got the same errors using the rigth steps to build a standalone with ftm objects.

I’ve posted on the ftm mailing list.

http://listes.ircam.fr/wws/arc/ftm-bugs/2010-03/msg00009.html


December 22, 2010 | 2:03 pm

Hey taprik, just wondering if you ever resolved how to make this work? I’m having exactly the same problem and it’s infuriating!

Nick


Viewing 4 posts - 1 through 4 (of 4 total)