Forums > MaxMSP

updreceive NOT WORKING

December 10, 2013 | 12:52 pm

Hello friends!

I decided to try to jump into the world of OSC programming and was having fun until I got to the updreceive object. It does not work. I am using Max 6.1.5 on a mid 2010 MBP.

I even downloaded a simple patch from TouchOSC that allowed me to send and receive. My iPhone receives the signal Max is sending it, but when I try to send signal from TouchOSC, Max is not receiving it. So, this tells me TouchOSC works great, while the object updreceive has dropped the ball. Unfortunately, tech support cannot help me with this problem and directed me to the forums for help. Does anyone have any thoughts or inside info they can share with me and anyone reading this post? Thanks.

Mark


December 10, 2013 | 1:34 pm

I think it’s odd that it tells you that udpreceive is broken, because normally such a problem would tell me, that there probably was a problem with the udp settings in touchosc and/or in the udpreceive arguments.

Link us to the patch, and post all your touchosc settings here. Oh, and your network settings too. Maybe we can figure it out, but unless udpreceive was somehow broken on your machine, then I think the problem is elsewhere.


December 10, 2013 | 2:34 pm

Wetterberg! Thanks for responding and offering a set of fresh and experienced eyes to my problem. The problem could be my lack of experience, but I will try to paint as big a picture as I can here.

First, let me address something you said in your reply. Max isn’t telling me that udpreceive is "broken". Its just not telling me anything other than "binding to port 8000" When I try to send signal from my iPhone 4S it doesn’t do anything. I don’t even know if it has bound to port 8000.

My TouchOSC settings are as follows

"Connections"
OSC: Receiving only >
Enabled
Host (left blank)
Port(outgoing) 8000
Port(incoming) 9000
Local IP address 192.168.0.102

MIDI Bridge: Not configured

CoreMIDI In(1/1) Out(1/1)

Here is my patch…

<code>

– Pasted Max Patch, click to expand. –

</code>


December 10, 2013 | 2:55 pm

You have the wrong settings.
Port incoming and outgoing always have to be the same.
Try this
local I.P Address 127.0.0.1 (Declares its the actual host computer, always good to test it just works)
so udpsend 127.0.0.1 8000
udpreceive 8000


December 10, 2013 | 3:13 pm

Andro,

Thanks for your tip. I can send messages with udpsend, but udpreceive is getting nothing. Your advice to make the ports the same did not work for me.

At this point, I can make a maxpatch that sends commands to my phone, but I can’t get my phone to control my maxpatch. udpreceive is not receiving.


December 10, 2013 | 5:43 pm

I found the solution on a different forum. I had to put my local IP address in. Once I did that, it worked like a charm. Thanks for everyone who spent even a second looking at my problem. Have a great rest of the week.


Viewing 6 posts - 1 through 6 (of 6 total)