Forums > Jitter

Urgent. Alpha trouble with multiple jit.gl.slabs- SOLVED !!

October 26, 2013 | 5:19 am

Hi Everyone,

Heres a patch (pure open GL, no video) showing a problem I just can’t get my head around (after hours and days and weeks of trying tuts and trawling the forums I’ve gotta accept defeat on this one).

Its the old age subject of blending multiple jit.gl.slabs together in a chain, I’ve posted an example patch which is very simple (especially for the Jitter wizards that walk this earth).

I have a dynamic re-ordering system with a bunch of jit.gl.slab effects which works perfectly except for the front layer becoming opaque and transparent. (this is not in the patch)
The 2nd problem is blending two chains together.
I would truly appreciate someone just diving in that (very small) patch banging in the right settings and showing me how this is done.
Is it incorrect settings ?? Can I do it and keep it all in open GL ??

I’ve got a big project coming up (deadline approaching) and everything else is working perfectly in my patch. After studying Jitter for 5 months I would seriously love to be able to do my 1st VJ show with a system that I created myself :)

Any and all help appreciated.

P.s. I promise when this is solved that I’m going to upload a very simple, clear concise Pure Open GL patch so any new people to Jitter won’t have to spend weeks finding out to how to make the basics work :)

<code>

– Pasted Max Patch, click to expand. –

</code>

  • This topic was modified 9 months by  Andro.


ak
October 27, 2013 | 2:49 am

I’m by no means Jitter wizard, but specifying shader for blending torus with kaleidoscope seems to work. [jit.gl.slab] without shader file remains unknown magic device for me ;). Also disable blend_enable in both videoplanes.

hth

<code>

– Pasted Max Patch, click to expand. –

</code>


October 27, 2013 | 3:39 am

Hi AK, thanks for looking, but the problem still isn’t solved.
I’ve tried using additive mode but the problem is that the torus AND the Kaleido Torus become "opaque"/semi transparent.(I know this has to do with alpha data, tried solving it with jit.gen, but thats still too undocumented for a noob like me :)

I need both layers to be "solid" so the slab/layer behind doesn’t show through.
Also in your example patch the cube isn’t visible as the back layer, this is why blend enable needs to be on with the videoplane in layer 2.

A clear example of parallel slab processing being blended into one mix shader for open GL is something I cannot find in the examples patch or here on the forums.

Any other suggestions anyone ? Do I need to use alphaglue, specify other arguments ? Or is this just not possible.


October 27, 2013 | 6:56 am

very quick mod with 2 alphablend shaders + just one videoplane, if i got you right it should now work as you want…

<code>

– Pasted Max Patch, click to expand. –

</code>


October 27, 2013 | 7:15 am

Tobias ! You sir are a life saver. I cannot believe I didn’t nail this one before with alphablend.
I missed the part of blending the 2nd jit.gl.node alpha !
You made my day, thanks a million !!!! :)


Viewing 5 posts - 1 through 5 (of 5 total)