Forums > MaxMSP

Urgent Problem with micrphone and noise, please i need help

May 13, 2010 | 4:29 pm

Hello,
For my final master project which i have to hand in in one week, i am doing a recording (using the ATR4697 external microphone : http://eu.audio-technica.com/en/products/product.asp?catID=2&subID=7&prodID=3702) of 35sec of people inside a room. This recording is written and after played back.
My problem is that i need to multiplicate the signal of the adc~by 20. to ear the recording when it is played back.
(which is not good for my speakers) and thus when the recording is playing back, there is a lot of noise,
I attach my patch,

Is someone has a solution to get a clear and audible sound?
Thank you,

Attachments:
  1. recording.maxpat

May 13, 2010 | 7:25 pm

:s thank you Raja i ‘ll try what you advice me,
but arre you in london?


May 13, 2010 | 8:55 pm

Hi there
I just did a quick search on that mic..
Am I correct that it is a battery powered condensor for tabletop use and that it comes with a mini-jack plug, not xlr?
If so, are you perchance plugging it into your audio interface in a line input (which jacks generally are) in place of a mic input. This would explain a lack of level.
Disregard this post if it’s pointing out the obvious and the problem lies somewhere else.
Regards,
Leigh


May 13, 2010 | 9:24 pm

yes it comes with a mini jack,
but i connect my mic with the imic using not the ‘line in’ but the ‘mic’ setting…


May 14, 2010 | 12:39 am

For some audio interfaces (like the imic) you can set the input level within os x.
Either in System Preferences/Sound/Input (which also has a input meter) or
"Audio Midi Setup".
Just a guess…


May 14, 2010 | 7:33 am

thank you mudang but i also tried this option but it did not change :s


May 14, 2010 | 10:42 am

Ok. Here’s what i would try:
Touch or tap gently on the microphone. This would normally give you a loud peak if your microphone, cable and gain are ok.
If this is the case than it’s problably not a appropriate type of microphone for your setting or the distance between microphone and sound source is too big.

BTW, my imic (old version) has some really nasty noise on its microphone input.

PS: Here’s another one: Have you checked the battery !?


May 14, 2010 | 2:45 pm

i will try maybe with a new battery but i do not think that the pb comes from there,
Do you have any idea which microphone i need to use to record people speaking inside a space
of 122*180*210cm?? :s
Thank you for your help :)


May 14, 2010 | 4:22 pm

i forgot to tell you, in quicktime it works quite fine
it is just when i record on max msp that the signal is really really slow,

grrrr so stuck and i have to hand it in 2 weeks :s


May 15, 2010 | 4:22 pm

Thank you for your response Raja,
So I made other tests and it seems that the pb come from my mic and max msp,
Because when i do some recording with my mic in quicktime, it works quite well
but when i put it in max msp the signal is really really low,
Also I did some tests with the build in microphone of my computer and it works fine
with my patch in max msp,

Should i buy a little mixer to boost the signal?
Should I buy another mic?
Is there some pb of uncompatibility between some mic and max/msp?

Thank you again a lot for your help,


May 15, 2010 | 9:54 pm

hmm..to me this sounds like a max/msp < -> audio driver issue.
I’ve also noticed some strange behaviour with my imic and max (samplerate is 0).
So maybe look for a driver update or another audio interface.


May 16, 2010 | 4:38 am

Hi
I think you have some problems with your patch as well . . . Check help . . .
Record~ will record to ‘sound’ for 35 sec as instantiated so why use poke as well?
Also maybe currently sending 0 to input 2 and 35000 to input 3 of poke?
Maybe use both outs of adc to input 1
Also output from record is a 0-1 index not samples of adc~
And the initial value of count is only a bit over 3 secs and is only triggered by the bang??

I think you may need to start over with your patch . . .
Record~ writes to buffer , index counts to 1 and bangs write buffer routine

Good luck and check the help for the objects you are using . . .

Cheers
MM


May 18, 2010 | 2:11 pm

another easy way of testing the mic is to put a pair of headphones in the mic connector… inverted speaker = mic (obviously it wont be good quality but it should be ok to test the patch)


Viewing 13 posts - 1 through 13 (of 13 total)