Forums > MaxMSP

using audio as LFO, optimizing and MSP questions

September 7, 2006 | 6:29 pm

Hello.

1st, I know very little about audio and ADC stuff.

question: to optimize my LFOs (im using things like cycle~ –
>snapshot), Ive lowered my sampling rate to 32000. Why does this
change my audio midi settings globally for all applications? (Max
4.6/ OS X 10.4.7). Is there something I can do so to change it?
Quitting Max doesnt revert it back to 44.1

Is there a more optimal method for creating fairly high resolution
LFOs within Max? Im under the impression that cycle~, ramp~ etc use a
LUT to do calculations at audio rate. Besides simply using table and
making my own control rate LFO, are there other options to speed
things up?

Simply turning on audio within my main patch takes my framerate down
almost 10fps, even with a lower sampling rate.

Perhaps poly~ and down sampling things for calculations?

Thanks for helping a (mostly) video only nerd :)

v a d e //

http://www.vade.info
abstrakt.vade.info


September 7, 2006 | 7:05 pm

all of the MSP-based oscillators i use for jitter parameter control
are in massively downrated poly~s. it’s a necessity.

On Sep 7, 2006, at 2:29 PM, vade wrote:

> Hello.
>
> 1st, I know very little about audio and ADC stuff.
>
> question: to optimize my LFOs (im using things like cycle~ –
> >snapshot), Ive lowered my sampling rate to 32000. Why does this
> change my audio midi settings globally for all applications? (Max
> 4.6/ OS X 10.4.7). Is there something I can do so to change it?
> Quitting Max doesnt revert it back to 44.1
>
> Is there a more optimal method for creating fairly high resolution
> LFOs within Max? Im under the impression that cycle~, ramp~ etc use
> a LUT to do calculations at audio rate. Besides simply using table
> and making my own control rate LFO, are there other options to
> speed things up?
>
> Simply turning on audio within my main patch takes my framerate
> down almost 10fps, even with a lower sampling rate.
>
> Perhaps poly~ and down sampling things for calculations?
>
> Thanks for helping a (mostly) video only nerd :)
>
>
> v a d e //
>
> http://www.vade.info
> abstrakt.vade.info
>
>


September 7, 2006 | 7:43 pm

Ah, that makes sense. ill play with that. I was wondering what I
might be doing wrong. Thank you good sir.

v a d e //

http://www.vade.info
abstrakt.vade.info

On Sep 7, 2006, at 3:05 PM, joshua goldberg wrote:

> all of the MSP-based oscillators i use for jitter parameter control
> are in massively downrated poly~s. it’s a necessity.
>
> On Sep 7, 2006, at 2:29 PM, vade wrote:
>
>> Hello.
>>
>> 1st, I know very little about audio and ADC stuff.
>>
>> question: to optimize my LFOs (im using things like cycle~ –
>> >snapshot), Ive lowered my sampling rate to 32000. Why does this
>> change my audio midi settings globally for all applications? (Max
>> 4.6/ OS X 10.4.7). Is there something I can do so to change it?
>> Quitting Max doesnt revert it back to 44.1
>>
>> Is there a more optimal method for creating fairly high resolution
>> LFOs within Max? Im under the impression that cycle~, ramp~ etc
>> use a LUT to do calculations at audio rate. Besides simply using
>> table and making my own control rate LFO, are there other options
>> to speed things up?
>>
>> Simply turning on audio within my main patch takes my framerate
>> down almost 10fps, even with a lower sampling rate.
>>
>> Perhaps poly~ and down sampling things for calculations?
>>
>> Thanks for helping a (mostly) video only nerd :)
>>
>>
>> v a d e //
>>
>> http://www.vade.info
>> abstrakt.vade.info
>>
>>
>


Viewing 3 posts - 1 through 3 (of 3 total)