Forums > MaxMSP

Using Jack Router

December 15, 2012 | 8:48 pm

Hi
My question is probably stupid, but I don’t get how to get the audio from applications like firefox to the sound input of Max via the jack audio pilot. Could anyone help me ?
After hours trying to connect the apps together, I think I am so helpless that I should be explained each step of the process.

Thanks very much…

Coralie


December 15, 2012 | 11:25 pm

Haven’t messed around with Jack yet, though I’ve been meaning to. Try checking out Soundflower from Cycling74. It’s super easy to use and will do exactly what it sounds like you need. Just set the default output of your computer to Soundflower, and then select Soundflower as an input source in Max. Simple as that :)


December 16, 2012 | 12:19 am

Hi Cody

Thanks for your advice. I had tried to use Soundflower some time ago, but I had finally chosen Jack when I had my former laptop, as it seemed slightly simpler for me to use. Now that my OS is more recent I think there are some bugs that have to be solved, which would explain why I have problems. I’ll try sound flower, I guess it should work.

Regards


December 16, 2012 | 1:33 pm

I works perfectly, thanks. The only thing is that I get clicks in the recording…. I increased the buffer size in Soundflower and Max, but it doesn’t seem to change much. Have you encountered the same kind of issue ?


December 16, 2012 | 4:59 pm

is there a difference between buffer size and sampling rate in each of your applications ?


Viewing 5 posts - 1 through 5 (of 5 total)