Using punctuation in COLL?

Feb 6, 2012 at 7:08am

Using punctuation in COLL?

Hi, Just a quick one,

Im storing questions in a COLL and answers in another, but due to (,) being used to index the items My questions dont read correctly.

is there a way to put commas in?

Thanks!

#61283
Feb 6, 2012 at 7:36am
– Pasted Max Patch, click to expand. –
#220934
Feb 6, 2012 at 10:09pm

Thanks a lot!!

#220935
Feb 7, 2012 at 12:01pm

Just played about with this a little more, and while i can get it use commas in the max window, I cant get it to display in a message box or text window properly.

I get;

‘this is what I get displayed when i try to use a comma/,’

any ideas how to get it to displayed in the patch corrctly as it needs to be seen by the user.

Thanks

#220936
Feb 7, 2012 at 2:00pm

Two ugly and ridiculous solutions. It’s time to get some kind of string datatype in Max instead of loosing time imagining such workarounds:

– Pasted Max Patch, click to expand. –
#220937
Feb 7, 2012 at 7:08pm

I imagine that adding another fundamental data type is a huge undertaking. There would be a _lot_ of objects to update.

Here’s another solutions:

– Pasted Max Patch, click to expand. –
#220938
Feb 8, 2012 at 3:17pm

Chris, in both your sprintf solution and my “atoi/itoa”, we need to add another workaround (like a route symbol) to get rid of the prepended “symbol” in case there is no space in the “string” stored in the coll.

I agree that adding a string datatype is a lot of work, but I’m sure it would be usefull.

Another trick, sligthly lighter, would be to use a umenu, with backslashes before the commas, to store and display the strings (soo much fun for a comma :-) :

– Pasted Max Patch, click to expand. –
#220939
Feb 9, 2012 at 1:54pm

thanks for the replys i used a bit of each patch to get the desired results.

sorry cant post patch, im at work.

#220940

You must be logged in to reply to this topic.